Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Hub and nest Unable to connect to wifi

Community Member

Hi Team,

I already have a Google Home Max connected and working from last year.

I've just bought both Google Hub and Nest Mini (,both second gen).

Both unable to connect to wifi. 

I've setup both successfully however the issue appears when I try to connect to my wifi network. 

Hub is asking me to "link account"

But neither are available in the Google Home app.

Reset router - confirmed no AP setting.

Changed Routers- still not working.

Updated Home App etc






Hi, thanks for replying. 

Some unknown reason, it decided to finally connect. I didn't reset them, just kept trying and it got through. Thanks. 

Community Specialist
Community Specialist

Hi folks,


Thanks for the help, @RachelGomez123.


@Antz8701, thanks for posting. I’m glad your issue is resolved now. I’ll keep this thread open for 1 more day. If you need further help, let me know.



Community Member

Update: not sure why/how - but I managed to get them connected. Didn't do much - just reattempted again and it worked. Happy but still at aloss as to exactly why it took so long. Thanks