cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Audio Connection Problems

DrWig
Community Member

I'm having problems getting both Google Home and Spotify to 'see' my Nest Audio device.  I have quite a few other devices that both see no problem at all (google home and nest mini's and chromecasts/chromecasts audio), but this nest speaker (newest device) is just sooo flaky in comparison.  

It works absolutely fine when using voice commands to start music, add to keep lists etc., but the home app often can't connect to it, and it doesn't appear in the list in spotify devices.

I've factory reset the device, completely wiped google home and spotify on my phone (and reinstalled) to no avail. 

The other odd thing, is that I can cast to a group that contains the speaker just fine, from spotify, just not the Nest Audio speaker individually....

Anyone got any other suggestions I could try? 

cheers

DrWig

10 REPLIES 10

DrWig
Community Member

p.s. the nest audio is on the same network as all my other devices (I do have another router setup as an access point, but devices connected to that are found no problem).  Same IP range etc

Here's how:
Load up the Google Home app.
Choose your Google Home device.
Touch the Settings gear.
Scroll down to Paired Bluetooth Devices.
Select Enable Pairing mode.
Choose the speaker you want to connect.

 

Regards,

Rachel Gomez

DrWig
Community Member

Thanks. That's not quite the question I'm asking, but even if it was, I wouldn't be able to do that as 9 times out of 10,i can't connect to it in the app to change any settings.

When it's playing (via voice command), the home app will find it, and it works fine with broadcast messages etc.. 

Muddi
Community Specialist
Community Specialist

Hi DrWig,

 

Thanks for reaching out. I appreciate @RachelGomez123 for helping here. I know how challenging it is when there's something wrong with one of your Nest speakers. A few questions: when did the issue start? How far is the Nest Audio from the router? What is the firmware version of your Nest Audio?

 

To eliminate network issues, please try setting up 2-3 of your devices using a different network like mobile hotspot. Please note that you will need two mobile devices for this setup (one will serve as a router and the other to be used to set up your speakers). Once done, check if your device will have the same behavior.

 

Let me know how it goes.

 

Cheers,

Muddi

DrWig
Community Member

Thanks for the reply.

The speaker has had issues ever since I've had it.

It one of the closest speakers to the router. 

Firmware is currently 1.56.299498

It's connected to the Internet fine, and works great with voice commands..... It's trying to cast to it (usually from Spotify) or connect to it using the home app that's troublesome.....

Router sees it fine, too (list of connected devices).

Cheers

Bruce

DrWig
Community Member

Here's what Spotify sees.... The only device missing is my 'kitchen speaker'.... On some rare occasions, it does appear.... (update, actually, there is another speaker missing...hmm) 

Screenshot_20221114-231548.png

DrWig
Community Member

ok, more invetsigations!  It turns out two of my speakers are being silly in terms of:

Not being able to be seen by Spotify

Not being able to be connected to by the home app (in fact, it often just crashed if I tried to go to the settings of these two speakers) and even if I did get to the settings, it said I probably wasn't on the same network so couldn't alter much.

The two speakers in question were both connected to my main router (as was my phone).  However, all the others were very likely connected to my 2nd router (setup as an access point).  All these worked fine!

So, to cut a long story short, it seems to be an issue with my main router.....rebooting the thing fixed the issue.  It was once I twigged two speakers were playing up, that I could work this out, so thanks for probing @Muddi 

I wasn't having any other issues with anything else, internet/network wise and factory resetting the speaker didn't help, either.....so pretty sure it's the router itself.....I'll see how long everything keeps working for now......

cheers

Bruce

Muddi
Community Specialist
Community Specialist

Hi DrWig,

 

I'm happy to know that we were able to isolate the issue with your main router. I'll keep the thread open for a while just to make sure that everything will be sorted out. Feel free to update the thread if you continue to experience the same issue after checking the main routers settings.

 

Cheers,

Muddi

Muddi
Community Specialist
Community Specialist

Hey DrWig,

How's it going with your Nest Audio? Let us know by updating this thread and the Community will be happy to lend a hand.

Cheers,

Muddi

Muddi
Community Specialist
Community Specialist

Hi there,

Just one quick final check in here since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need assistance, feel free to start a new thread in the community and we’ll be happy to help.

Cheers,

Muddi