cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Hub Max camera won’t work

Shon
Community Member

My Nest Hub Max camera won’t work. It was working fine until about 2 and 1/2 weeks ago. I was using it for Google Duo, and also for nest camera home monitoring. Now it does not show up on my Google home or on my Google nest app. I tried resetting the router, resetting the hub max, going through all the settings, and still the camera does not work. I went through the threads listed here and it appears that many other people have had this same problem, but an earlier thread addressing the issue was closed. I could not reply to that thread and so I'm starting a new thread at this time. The problem is, I received this as a Christmas present less than 1 year ago. I do not have the receipt or proof of purchase, therefore I cannot go through the normal warranty or claim steps.

 

Edit: Here is the solution. Follow these steps carefully: 

1. Completely remove the nest hub Max from the Google home account

2. Reset the hub Max. You could also restart your phone for good measure. 

3. Open the Google Home app. DO NOT SELECT "SET UP GOOGLE MAX" ON THE HOME PAGE. Instead, use the "+" symbol in the top corner and then select "set up device". Follow the instructions and add the Google max to your account again. 

4. After the Google max is successfully added to your account, you will need to set up there camera again. Go back to the Google Home app homepage and in the middle of the page you will see the option to "setup hub Max camera" (or something similar). Follow those instructions and your camera should be working again. 

If this method doesn't work, another method that somebody reported trying was to uninstall all of the Google Home devices, including door locks, cameras, security, etc.  

 

1 ACCEPTED SOLUTION

M1keS
Community Member

.....I spent several hours going round round and round with this,  then eventually got it working.

Here's what I did.

1. Factory reset the hub max

2. Remove the hub max  from Google home app

(rebooted  the phone with the home app, probably not nèeded)

3. Click + to add new device in the Google home app.

When It detects the hub max , I selected that, but also noticed there was also an extra  option to 'set up as a new device', so I selected that.

Follow through the setup screens, and when it's complete  select the hub max in the Google home app. Then select the "setup nest cam" option. Follow those instructions, and then it , finally, worked!

 

So the only thing I did differently was to select the 'setup as a new device' option on the home app after it detected the hub max (despite having done a factory reset)

View solution in original post

165 REPLIES 165

Same issue.

JohnG
Community Member

Same here. Installed Google Nest Camera and lost camera on hub. Tries to connect unsuccessfully 

mevans336
Community Member

Just bought a Hub Max and 3 Mini's - already had Nest Battery Doorbell - cannot connect to camera either, but it works fine in an app like Zoom.

Estefano
Community Member

Same here. I’ve done all the steps as everybody else. The camera works fine for video calls but not for live stream. I just can not turn it on…

BigD
Community Member

The bought the max hub and tried to get camera working. No luck. Returned it and brought home a new one. Same issue. Only have 2 thermostats installed before max. Maybe I should return this one and bring home another and keep doing it until Google gets the message. 

CNSJoseph
Community Member

What is the solution to fix this issue? Expensive display that doesn't display. Another Google product that has failed and going back to the retailer.

ReneeL
Community Member

I’m having the same issues. Mine is new and the camera won’t work. 

Rich2
Community Member

Same here 

Krisnepola
Community Member

We are having the Same problem

Mcph
Community Member

My brand new hub is doing the exact same problem brand new out of the box. Are you able to assist please. Have tried resetting everything but nothing is working.

Have 100 % of the same issue. Camera will not connect and the home monitoring features selection will not select. 

Following this thread if you guys find solutions. 

KimC
Community Member

Im having this exact problem. I’ve done the trouble shooting tips and it still won’t turn on. 

JohnCuser
Community Member

Hi Kim, can you please detail the problem your having, and the steps taken.  

Barto189
Community Member

Hi Frances, I have an issue similar to everyone else when I installed my doorbell I lost the camera on the nest hub max. I had to set up a whole new home just to get the doorbell to work and then install all the products now it seems I have to do it all over again to get the nest hub camera to work again. My question is if I do this will I lose the doorbell camera again. This all seems ridiculous and time consuming?

Help! My nest cam has never worked on the display and it’s so frustrating. I’ve followed these steps done the reset and it still just says “something went wrong” right at the end. What do I do? I’ve also got a doorbell and a camera outside. So do I need to remove and set everything back up from scratch?? I don’t even know if I still have the Qr codes for the doorbell and camera so I don’t want to remove them just in case. 

Hykingo
Community Member

Hello, I am having the same problem. But I can’t get it fix with the above solution. Any other suggestions? 

Rich2
Community Member

Is this fixed mine did it to and I just bought it brand new don’t work the camera

Joel_
Community Member

Hello mate. 
I’d  appreciate if you could do the same for me. 
I’ve tried all the steps above multiple times and I still can’t get it to work. 
Thanks

JohnCuser
Community Member

Hi Joel_ 

did you get yours working? If not, please describe the steps taken so we can try and help.

Mine is doing the same thing. Have tried to remove, reset, reboot, removed my nest cam and then tried adding hub max but no luck! What do I do?

Hi Jclegroves,

remove all cameras from your Google Home (factory reset them to be safe), then add them back starting with the hub max. 

P.S. it’s a pain to remove and add the doorbells, you have to physically remove them from the mount and plug them into a usb-c charger. I ran an extension cord for mine because I have it installed by my gate.

 

Good luck:-)

FWIW, I can confirm one does not have to physically remove the doorbell (battery version, 2021). I repeated these steps twice to make sure it worked (worked twice). I posted my steps earlier.

Just read your solution, and it looks great! Basically what I did, but with more specifics and less steps. Good job!! These forums would be great if they actually had a moderator to pin the good post up top.

Yoherm
Community Member

I’m going through the same thing for a week 

ColtyD
Community Member

I am having the same issue.  I went through all the suggested steps and the camera is still not working.  Has a fix been pushed out for this? 

PD80
Community Member

There is certainly something going on because my hub camera just stopped working all of the sudden. Can you assist?

Tproveau
Community Member

Just checked, mine is fine. I have lots of smart devices in Google home, however no other cameras.

Kris
Community Member

I've been struggling with the same thing for months. I actually purchased my home hub max a couple years ago and it worked great until earlier this year, and no matter what I do, it does not recognize it use the camera. It must be a software issue, because it worked, now it doesn't. Duo was one if it's most important functions is our household, we even used it for piano lessons. 

Jezsmith720
Community Member

Same problem, bought like 1 week ago and has never worked. Software issue as the camera works on Duo. But fails to recognise or “turn on” from the google home app nor the hub max itself for live viewing. 
Sending mine back and buying a competitor.

I have exactly the same problem, it’s doing my head in. About time google did something I reckon!

Okay, so I had the same above problems, Nest Hub camera would not work during set up process when Nest Doorbell was set up already.  I finally made the Nest Hub camera work by deleting the Nest Hub and Nest Doorbell altogether, and installing the Nest Hub FIRST and making sure the Nest Hub Camera was set up first and working.  Only then....  I installed the Nest Doorbell last, and that seemed to have solved everything. Whew.....  I hope this helps everyone!  John.

ClassicGirl79
Community Member

Adding to the chorus. My Hub's camera also stopped working - I had no idea until we tried to Duo the grandparents and it just refused to work. We've reset both router and unit to no avail. In the Home app we get the message "the camera has been switched off on this display." The Nest app says the camera is offline. The hard switch on the back of the unit is on; there's no reason I can find that it should be off. Any help appreciated. 

phoopsta
Community Member

I found the only solution to this problem. This was to remove all of my devices and then add the Max.

 

What a pain and a waste of time. 

 

Edit: Yup, I tried it again (for science!). If I add a device BEFORE adding the Max, it breaks the camera functionality. When I add the Max BEFORE adding other devices, the camera functions fine. 

Sounds like there needs to be a software update to address this.

I miss Nest 😞 

Thanks phoopsta!  Life saver.  Agree very annoying that Google don’t fix, or at least know their products well enough to tell you.

Aramis
Community Member

Am wondering if this will work for me, and whether your situation is similar.

I purchased the nest hub max.  Camera worked fine at first.  I then purchased 3 mini speakers, a max speaker, and a doorbell.  I installed them all.  But likely played around with the max hub at some point.  Now the camera is not working on the max hub, but everything else about it seems fine.


Do you suggest that i uninstall all devices, then re-install the hub first, followed by the other devices?

Gavinlr3
Community Member

That is what I did following what phoopsta suggested and it worked and is still working.

EazyE
Community Member

This worked for me but with one caveat.  I deleted everything in Home except my Google Wifi Router Points (besides the hub max and routers, I only have a Nest Doorbell and a smart things tv so far).  Then, when I added the Max, the camera began working (I could see the green light coming on for the first time).  However, it was still telling me that it was offline in the home app, and I couldn't view anything.  At this point, I rebooted the router connected to my modem, exited the home app, re-entered and only then was I able to view anything via the Max's camera.  Still need to try to get my doorbell working again.   Thanks Phoopsta 

EazyE
Community Member

Just to follow up on this, after I removed the devices from Google Home and added back the Hub Max and got it working, I was able to successfully add the Nest Doorbell Battery device from scratch (removed the doorbell/rescanned the qr code again, etc), and they come continued working. It's been a couple weeks without issue yet.

Hey, I had to do this when I installed the nest doorbell as I couldn’t get the camera to come up on it. Do you have the doorbell and if so when you migrated all the appliances again did the doorbell and the nest hub work together?