Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Hub alarm just don't work

Community Member

Hello, got my Nest Hub in November 2022 and still haven't managed to make the alarms work...

Tried every troubleshooting guide on this forum without success.

I use a regular alarm at 7.00am every day except on weekends, it also should start a routine that plays local radio podcast (franceinfo). 

For now I've put an alarm on my phone at 7.05am to wake me up if the nest hub alarm doesn't ring. Most of the time I wake up with my phone and not with the nest hub.

At 7.00am it displays the "good morning" screen with the "close" and the "see sleep tracking" button but it doesn't make any sound and don't start my routine.

Sleep tracking seems to work fine but I tried to disable it, got similar results.

I also use the nest hub to play music with the Chromecast feature when I sleep but the playlist is shorter than my sleep time and isn't set to repeat so when the alarm should ring nothing is currently playing. Tried to don't play music, same results.

Also sometimes when it doesn't seem to work at 7.00am (and displays that "good morning" screen) and if I don't click anything, it will start playing the alarm music at 7.10am for some reason.

If for some reason the alarm works at 7.00am the alarm music sometimes stops before I click anything and the routine seems to start correctly (but says french words with english accent for some reason) and the news podcast just stops for no reason before the end.

If I try saying "ok Google, bonjour" it starts my morning routine without any problem and with the right language speaking.

It's working fine like 2 days in a month...

Tried resetting everything, changing Google accounts, trying other podcast, disabling every setting I could find, adding more alarms... All same results...

Weirdly enough pretty much all other features on this nest hub seems to work just fine, it answers fine for any voice command and all apps seems ok.

I really want to use my Nest hub for alarm but I just can't now.

Please provide me a fix, i tried every single troubleshooting i found on this forum...


Community Member

-Alarm is correctly configured  (it works sometimes)

-Restart doesn't fix anything

--Firmware is up to date

--I factory reset twice, didn't help

-Time zone is set to the right one (UTC+2 with DST on)

Community Specialist
Community Specialist

Hi folks,


Thanks for the help, RachelGomez123.


123321mario, thanks for posting. Since the steps didn't work on your end, we'd be happy to take a look into this for you. Please fill out this form with all the needed information then let me know once done.




Community Specialist
Community Specialist

Hi there,


I wanted to follow up if you are still in need of any help. If so, please fill out the form above.



Community Specialist
Community Specialist

Hi everyone,


Just one quick final follow up since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need help, I would be happy to keep it open. If there's more we can do, just let me know.