cancel
Showing results for 
Search instead for 
Did you mean: 

Will not set up

WLY
Community Member

I have done every work around I can find on this community and I still can't get the Nest Hub 2nd Gen to set up. 

The furthest I get is "Connecting to WiFi" and it stays there. I have tried connecting to the "NestHub" WiFi option and shutting down my app and restarting the process and still nothing. 

I am using a Pixel 6Pro. My WiFi is fine. This is a brand new Hub. Should I just return this?

Oddly enough I tried to connect a Lenovo Smart Clock 2 (which I bought prior to the Hub) and I had the same issues. The Google Home app even indicated to set up the device on a different phone that isn't my Pixel (it literally said Pixel, not "your current phone"). Which is why I went ahead an bought the Hub cause I figured it would be a more streamlined set up process.

 

Is this a common issue with Pixels? 

So confused and frustrated and let down since all I do is talk up my device. 

 

Any suggestions would be helpful, though I think I might have tried almost everything. 

5 REPLIES 5

rustyz0r
Community Member

Okay Dude, I've just spent 4 hours today messing around with the Nest Hub Gen 2 and Nest Hub Max I bought. Like you I tried everything online from resetting routers, clearing saved passwords all that stuff... nothing worked. I've finally got it working as follow.

In case any of this is relevant my specs as follows:

* TP-Link Archer 1600V Set to Bridge Mode (This is ISP Modem/Router).

* Asus ROG GT-AX6000 Router (Router Only).

* Samsung S22-Ultra used to Pair with Google Home.

After a lot of trouble shooting I managed to get an internet connection on the Nest Hubs WHILE connected to Router after I took the Modem/Router out of Bridge Mode. Switching back to Bridge Mode and the issue came back straight away on the Nest Hubs (no internet connection).

Thankfully all this messing around made me realise I was using Google DNS on the Modem/Router, while the Router was getting my DNS automatically from ISP. So after changing Modem/Router back to Bridge Mode and ensuring my Router was using Google DNS I've literally just watched my Nest Hub Max successfully connect while typing this.

TLDR: Make sure you are using Google DNS (or at least not automatically assigned from ISP, maybe others work) at your the correct level (either your Modem/Router, or your Router if you have Modem set to Bridge).

Azarco
Community Specialist
Community Specialist

Hey folks,

 

Thanks for providing the steps that worked for you, rustyz0r.

 

MplsCustomer, appreciate you providing that helpful forums.

 

WLY, have you tried the suggested steps by rustyz0r? You can try setting up your device using a different phone to isolate the issue. Let us know if you still need help with this.

 

Best,

Alex

Azarco
Community Specialist
Community Specialist

Hi WLY,

 

I wanted to follow up and see if you are still in need of any help. Please let me know if you are still having any trouble from here, as I would be happy to take a closer look and assist you further.


Regards,

Alex

Azarco
Community Specialist
Community Specialist

Hello everyone,

 

One quick final check in here since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need assistance, feel free to start a new thread in the community and we’ll be happy to help.


Thanks,

Alex