Showing results for 
Search instead for 
Did you mean: 

Can't enter serial number

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original Poster: Tracy Foor 

CAn't enter serial number into app


Community Member

I have the same problem

Community Member

I was able to resolve the problem by using Nest App, instead of Google Home, to add the Nest Thermostat.

I tried both Google Home and Nest App with same result. The only way I was able to add the new thermostat was to create a brand new home account. I just need to migrate all my old devices to the new home.

Had to do the same when first installing in July. NOW if I reset to factory the Google Home app asks for QR and works.

Community Member

No support on this? 

Community Member

I have the same problem. It's just maddening that Google simply ignores this issues and others regarding "migrating". What to do?!

I think you'll find there is no marketing or advertising money to be made on this. So it will be bottom of their agenda....

Community Member

I have the exact same issue re: the last 4 digits as described by mbelanger. What's the story Google? Automation might help our lives become more efficient, but there shouldn't be so many road blocks along the way!


Community Member

Same issue

Community Member

Same here.

Community Member

Same here.


What is the solution Google?

Community Member


Where’s Jackie Chiles when ya really need him?

Community Member

I'm able to enter the Key but the next screen in the Google Home App and the Nest App asking for the last 4 digits of the serial number will not accept the information.   Tapping anywhere on either of those screens does not produce a space and the keyboard.  

I've uninstalled both apps and reinstalled them, I've cleared the cache in the Google Home App and still not

able to enter the last 4 digits of the Nest Thermostat serial number.  PLEASE TELL ME THERE'S A FIX

Thank you

Community Member



Thank you - this worked for me in setting up my cameras.

Community Member

Oh my god. I'm not sure to be frustrated or relieved that I'm not the only one w/ this problem. This is the screen in question:


Screen Shot 2022-07-15 at 10.34.38 PM.png


 My only solution was to re-add the thermostat in the Nest app and then have it propagate to the Home App.

Community Member

Had the same issue as everyone else. I stead of selecting nest thermostat select other. Then install the nest app. It's a blue square with white house silhouette. You can use it to install then operate with Google home app. Such an annoying install. But all done and working fine. Good luck!!

Community Member

Removed plastic strip from AA battery and the serial number auto filled. Nest must be powered up. It's that simple

Community Member

I am replying from memory to the group- I didn't think to take notes- (I am doing this after several frustrating days of clicking )

I read "somewhere" to get the "second" APP- the BLUE NEST app- I did this- so I now have two apps

My NEST Thermostate was installed

I was told to wait a day before trying to install or connect any apps as the battery had to charge

I didn't look or I would have said no to this brand- I do NOT like Google

  1. My two days then started- the QRcode would not scan
  2. The battery went dead with all attempts
  3. I could not type the last four characters of the serial number
  4. I was using three devices at once to try this (I am a computer teacher- I figured I could win)
  5. I reset the wifi and modem 
  6. I deleted everything and started over

Somehow on the thermostat words came up when I had the BLUE NEST APP on and was standing with the phone app only an inch away

Note my distance was an issue- I had the NEST APP and had tried the set up earlier in the day and nothing- I was about three feet away- I refused to give up and decided to try one more time.

The second time that worked- I hit the button on the thermostat and decided to see if I could SPIN through settings and I decided to hit the NEST APP about the same time- TA DA- well TA DA for me at least- my phone and the thermostat decided to communicate. I had the phone only an inch from the thermostat so I could manipulate both devices at once. (proximity)

These words walked me through setting up the thermostat and using the codes NOT scanning 

Why when the price tag is what it is are we not provided a QRcode on a sheet of paper and not on the back of the thermostat? Plus- the directions in the box stink- if we are on our phones trying to set up something- again wouldn't it make sense to provide more in the box?

Anyway- there are a few references within this thread that do mention you will get your answer by getting the second app- but there are a lot of places AND FROM GOOGLE SUPPORT themselves that suggest all the other items I just listed that simply wasted my time.

The biggest one is why do they not simply respond to any of us here or why not fix their APP and allow the QR code to work the first time anyone of us tried it?

Community Member

Has there been any traction with this issue? I cannot add "as new device" as unable to select last 4 digits of SN as no selection appears. I cannot add as "works with google" as you need to link to a nest account, and you cannot create a nest account any more as it uses google sign in.

I have literally spent hours trying to get this working and I wish I had never bought the device now. 

It would appear that despite this issue being over 12 months old there is still no fix from Google.

I am annoyed as I have bought into this ecosystem yet I cannot control the device by voice, and no other member of my family can operate it via their phones.

Please fix this Google with an update to the Google Home App, or alternatively post a bullet proof solution here so we can implement by ourselves. 


Are you by any chance trying to install a Nest Learning Thermostat?  If so, there have been several recent posts about this.  The Nest Learning Thermostat gets installed in the Google Nest app and then is supposed to automatically appear in the Google Home app.  (Just another aspect of Google's 2-app approach to Nest.). And for some reason, instead of getting an error message telling the customer to use the Google Nest app instead of the Google Home app, they get the screen where they're unable to enter the last 4 digits of the serial number.

Hello, exactly this issue. I'm hoping the new home app will fix this. Anybody subscribed to this should get pre public release soon. 

I bought a new home 500 miles away.  It has a Nest Learning Thermo in one area and a separate Nest Thermo (for heat pumps?) in another.  This weekend I made a quick trip to the house and did factory resets on both.  Then I went through the basic setup, selecting language and manually entering the wifi info.  I saw each unit connect to the internet and check for software updates, and  both were already up to date.

Then I tried to connect them to the Nest App.  Using my phone and the therm's QR code display, I kept getting errors that there was a problem with the Nest service and to try again later.  Sometimes the app was so dumb that it snapped a picture of the QR code while I was still positioning the phone, so it only had a partial image.  Or sometimes it would go right back to the Nest app home screen as if nothing had happened.  I also uninstalled the Nest App and reinstalled the latest version on my Android phone.  Didn't help.  Also installed Nest on my tablet.  Got the same result.


After trying the QR codes multiple times, I finally tried the Entry code plus 4-digit serial number method.  At first the app took the 6-character Entry code and then asked me to select the 4-digit serial number that matched what was shown on the therm's display.  But the app wasn't showing my any 4-digit or 4-char codes to choose from.  And there was no way to get past that screen.

The next DAY, the Nest app's behavior changed slightly.  It still wouldn't connect using the QR codes, but the Entry codes started producing a single 4-char serial number to choose.  The Entry codes from both therms resulted in the same 4-char serial number ("7SZ2") in the app, which made me think the server is messed up.  The serial numbers from my two therms were different from each other and different from the code displayed in the app.  I went through this process multiple times and always got the same incorrect serial number to select.    I ran out of time and had to return home.


On a whim, I decided to choose the non-matching serial number, since nothing else was working.  But eventually that choice also failed to link the therms to my account.

I spoke to a rep on the phone.  I explained all of this, and the fact that I am now 500 miles away from the house and the thermostats.  He claims I need to be right in front of each unit in order for the the "pairing" to work.  If I am just typing the Entry code characters into the app, I don't see what difference it makes where I'm standing.  The Nest App should show the correct serial number sequence, or Google should be able to explain why it does not.


I love Google's other products and services, but this Nest fiasco is infuriating.


There were a number of postings in this forum yesterday from customers who were having trouble accessing Nest services or being unable to log into the Google Nest app from some accounts or some phones.

Google Nest's install process uses bluetooth and Wi-Fi for the install, so you need to be on the same Wi-Fi and physically close to the device you're installing.

In addition, this page says: "You’ll need to be able to touch your thermostat to add it to your account in the Nest app. This means that you won’t be able to add it remotely. After you’ve added your thermostat to your account you’ll be able to use the Nest app on your phone, tablet, or computer to control your thermostat from anywhere."

Community Member

Like others, I ended up installing the Nest app, which really seems to go against the spirit of having a single home management app.

Community Member

Hello, nest app is initial setup, I need integration of nest app into home app to allow other family members to control the temp and to allow all to use voice commands. I just want to be able to control it by voice when I get into bed and have forgotten to turn it off for the night. 

Community Member

Just come off chat with support. here's the fix that worked:
1. REMOVE thermostat from Nest app
2. Go to Settings in the Google Home App> press on Add Device>New Device (press Next) > It will say "Looking for devices" > Select Thermostat > Select Thermostat > Other Nest Thermostats (make sure you choose other) > Go to Nest App
3. Add thermostat using QR code or Entry key
4. Go BACK to GH app, then back again
5. thermostat now appears in GH app, and also in Nest app

Community Member

Incredible! The struggle is over. Thank you very much!!!!

Community Member

Tried as above still wont let me enter the last 4 digits of the serial number


What Google Nest device are you trying to install, and in which app?

Community Member

Brilliant - just stepped through this and it works. I really appreciate you spending the time to post this and help other members. 

Community Member

I finally got it to work, but only because I added the thermostat in the Nest app. It's showing up fine in the Home app now. Google, fixyer**bleep**.

Community Member

Same issue

Community Member

I am having a similar problem, the home app is asking for a9 digit code but the code on my nest wifi point is 8 digits.

Community Member

I have the exact same issue. Google is deafing with its replies... Not! 

Community Member

Well, here it is, January 30 and same issue.  Troubleshooted all the fixes, tried the Nest app instead of the Google Home app, tried a brand new Google Home account, tried both apps on both a Pixel phone and a Chromebook . . . nothing worked.  Over and over, you just get to the "enter the last digits of the serial number" screen and it's a dead end.  Nowhere to punch in the serial number, just a blank white space on the phone under the instruction to type in the serial number.  On the Chromebook you can go at least hit the back button, but on the Pixel phone app, it just doesn't do anything.   Disappointing.  Returning.

Community Member

Same issue as all the above - cannot enter serial number in setup. Has anyone been able to resolve this?


When you say "same issue as all the above", what issue do you mean? There are actually several reported. The most common cause for getting a "Choose the last 4 characters of your device's serial number" with no serial numbers listed is due to mistakenly attempting to install the Nest Learning Thermostat or Nest Thermostat E in the Google Home app instead of in the Google Nest app. Another cause is trying to install a Nest thermostat remotely. Yet another is trying to install a camera in the wrong app. Yet another seems to be due to problems on Google Nest's servers, because it was resolved by trying the process on the following day. Still others are unclear.

Nest has supposedly been superceded by goggle home. So why do we have to set up thier latest equipment on an old outdated defunct app?

I can set it up on the nest app fine np.

But then it won't show on goggle home app even though I migrated nest to sync with goggle home.

And the mini nest cannot be set up on nest only on goggle home. 

So therfore issue is you have thermostat on one system ...your speakers on the other. They won't talk to each other. So therefore cannot use voice commands to adjust heating. Which is one of their main selling points.