Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Cannot unlink devices from my Google home App/Account

Community Member

I can't unlink 2 devices from my Google home Account. I no longer have access to these devices and it will not let me remove then. Google Nest often confuses my voice commands with trying to play music/videos on these devices which I do not have anymore.

When I try to "Remove" device from settings, I get an error message saying:

Unlinking account from device failed

 Unlinking account from (null) was unsuccessful. Please try again later.


How do I get these 2 devices removed from my account??


IMG_4829 2.jpgIMG_4827 2.jpgIMG_4828 2.jpg


Community Member

I to am having this issue. Sony TV that I cannot 'unlink' no matter what I try. I've even created a new home and moved everything but it follows me

Community Member

Bumping this thread again.  It's hard to believe that there still has been no meaningful response to this issue by anyone within Google.  Not even a "we're working on it" type of response.  

I was able to fix it by searching for it under my account and deleting the link. In my case I searched “Sony” and removed all links. It removed it instantly and my now Google Home is looking normal again 

That option has been tried in this thread.


For me specifically, those links aren't showing after being unlinked/disconnected within the app. 

That doesn’t work for me, unfortunately.  There is no “Sony” anything that shows up in the list.  I have already removed the devices from the “My devices” page as well.  They still won’t go away.

For me it was the name of my device

The devices aren't showing up in any form -- not by brand name, model name or otherwise.  As far as the Google "backend" is concerned, they don't exist.  And yet, they persist in my Google Home as devices "linked to me".


I am going to have to create an entirely new Google account and recreate all my devices and routines under that account, in order to resolve this issue.  All because Google created a system that does not allow users to delete devices from their home setups.  It is absolutely stupid and nonsensical.


I look forward to the day that Apple comes out with a dedicated smart display, and I can throw all my Google/Nest devices in the trash.

Community Member

I have this same issues with a Google Chromecast (TV with remote).  It would not cast from any device, so we did a full reset on the Chromecast via the TV using the remote and re-added it to our Google Home.  It now works just fine.  The old not working tile still remains in GoogleHome and the Casting Device list from within any app on our phones / iPad etc. 

There appears to be no way to get to the "Device Settings" for the Phantom Chromecast to remove that device.  It is very confusing as now we have a Phantom Device listed as available for casting but there is nothing to cast to.

I have tried various suggestion above but nothing works.  @google please help us with a solution.

Community Member

I think I may have found a solution. I had a zombie device that I was not able to delete. Here's what I did

  1. Open device settings
  2. Click "Home"
  3. "Add another home"
  4. create a new home and move only the zombie device there
  5. Delete the newly created home and the device gets deleted with it

when you create a new home, you do not have a guarantee that all devices will move to the new home.  Also, it's an expensive operation (meaning, it takes TOO much time).  I've done this and it caused all kinds of issues with my devices (when I had fewer devices), now that I have over 50+ devices, this is an impossibility.  This shouldn't be a workaround, it's ridiculous that you cannot just force delete a device from your home, period.

Yeah... Just tried moving all of those devices to the new home > deleted the new home > went back to my actual home, and they are still under "Linked to You". Unfortunately, this didn't work. 


 Still showing up. It really shouldn't be this difficult to remove a device from a home. What's the issue here!?

Let me give that a try quick. 🤞🏼