cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung hw-990b soundbar is not playing music when i ask google assistant

Gytis
Community Member

I connected SmartThings app, added my soundbar later on i added SmartThings soundbar to google home. when I ask google assistant play music on the living room soundbar it says - "sorry i don't find any devices on your home that can play music". I can play music from spotify and select soundbar as an output and works. why google home can't play music on soundbar when it's visibly added there? how to setup that soundbar as a default home speake? (i don't want to connect it as a default speaker to google mini via bluetooth because it's laggy)

5 REPLIES 5

Muddi
Community Specialist
Community Specialist

Hey Gytis,

 

Thanks for sharing details about the issue here. I know how challenging it is when you can't play music on your soundbar via voice command. To confirm, do you have a Google Home/Nest device? What specific Google speaker or display do you have?

 

Please note that there are limited commands or actions that you can do with your Samsung soundbar when it's connected via the SmartThings apps. You may want to check with the manufacturer of the things that you can do. If your soundbar has a built-in Chromecast device, you can  set it as a default speaker, or play music via voice command using your Google Home/Nest devices.

 

Cheers,

Muddi
 

Gytis
Community Member

Hey, thanks for answering, I will split this issue into two, so it would be easier to discuss possible solutions.

FIRST ISSUE:
I have Google Nest Mini and Samsung sound bar HW-990B.

https://www.samsung.com/sg/audio-devices/soundbar/q990b-black-hw-q990b-xs/

I has build in chromecast. I had setup that my google nest mini default speaker would be Samsung HW-990B (Main soundbar) but music keeps playing on Google Nest Mini. It's clearly a bug that selected device is not playing music but sound keeps playing on Google Nest Mini (sorry if i'm wrong). If it helps I can record video of it and post it somewhere.

SECOND ISSUE:
If I select pair device and connect sound bar via bluetooth, it works but it get stuck on beginning of every song. But why I have to pair it via bluetooth separately when I select option which is displayed on selection.
I tried to explain this issue in separate post, my internet speed is good, I don't have any problems playing music on steaming movies, Google Nest Mini and sound bar distance is minimum  
https://www.googlenestcommunity.com/t5/Speakers-and-Displays/Every-time-spotify-goes-to-the-next-son...

325950715_498539029118299_7011265708263659729_n.jpg

326163521_856429318745941_1178795487644063005_n.jpg

326052594_559489242728325_4084946484698855422_n.jpg

Muddi
Community Specialist
Community Specialist

Hey Gytis,

 

Thanks for the information. What is the cast version of your soundbar? Have you tried doing a sequential reboot? If not, please reboot your Nest Mini, soundbar, and router by disconnecting them from the power source and leave them unplugged for 1 minute. Once done, plug them back one at a time with intervals.

 

If it is still the same, reset your Nest Mini by following the steps below:

 

  • On the side of your device, switch the mic off. The lights will turn orange. Press and hold the center of the Nest Mini, where the lights are on top. After 5 seconds, your device will begin the factory reset process. Continue to hold for about 10 seconds more, until a sound confirms that the device is resetting.

Keep us posted.

 

Cheers,

Muddi
 

Gytis
Community Member

Hey, thanks for answering, I tried sequential reboot, it didn't helped. now I tried do factory reset and completed steps all over again, it didn't helped too, I experience same buggy behavior.

 I don't know which version of cast it has but I know that on samsung website it has build-in chromecast.
You can specs online, this is the newest soundbar samsung has, it's weird that i'm having troubles with it.

Samsung Q-Series Soundbar HW-Q990B

Gytis_1-1674126452754.png

 

 

Gytis_0-1674126365994.png

 

Gytis
Community Member

@Muddi any luck finding the fix for my problem with given information?