Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

nest E error TD023 nest app icon with arrow

Community Member

am trying to re-install a Nest Thermostat E for after the device has been off for some time and the device does not connect to the Nest app nor can I get into its settings. It shows the home screen for a while while blinking green then it makes on blink orange then goes to the mobile phone with nest app icon with an arrow.  

When I do try to connect with the nest app I get an error message that something went wrong with error code TD023. I have gone through various resets that are possible without any control of the nest thermometer. So 10sec reset and battery disconnect 10sec reset plus 3sec press on base. 

Had exactly the same problem with a previous Nest E thermostat 2 years ago and in the end it was replaced, so this is the replacement, which worked for a while and I am now having the same problem. Please see below what I have tried up until now:

  • The thermostat was totally new
  • the phone that was trying to connect was directly in front of the thermostat
  • tried different phones same result
  • reset was double click and hold for 10 secs
  • tried resetting app on phone
  • tried turning off all bluetooth in the room
  • tried battery reset
  • tried adding new home in the nest app
  • tried using hotspot from another phone while trying to connect with bluetooth. 
  • tried turning on airplane mode and then restarting bluetooth 

All of this failed with the first model and was done with tech support with Google. In the end they asked for the serial number and when nothing fixed the problem they sent me a new model and it worked first time until it didn't a few months ago. So I have gone through all those steps again with the new model and again nothing works.

Please don't send me the usual string of article links, etc. As you can see from above I have tried it all, I've been there before. This is the second model that shows exactly the same type of failure. May I suggest we both save both our time and effort and send another replacement unless you have a new solution.

Kind regards



0 Kudos

Community Member

I’m having the same issue, has nest sorted it out for you?

Community Specialist
Community Specialist

Hey folks,


The TD023 error can occur when your thermostat is unable to connect to your phone or tablet over Bluetooth Low Energy (BLE). This can happen because:

  • Your thermostat isn’t powered on.
  • Your thermostat is outside of Bluetooth range.
  • Your thermostat is already added to another account.

Try the troubleshooting steps below.

  1. Make sure that the thermostat is powered on.
  2. Move your phone closer to the thermostat.
  3. Reset the account connection on your thermostat. Note: Reset of account connection varies on different thermostat models. Make sure to do a reset connection, and not perform a factory reset of your device.



Community Specialist
Community Specialist

Hi all, 


Chiming in — just wanted to check if you saw our response above and you still need help? 





Community Member

Hi, really sorry for the very delayed response, I just saw your message now. They finally replaced the thermostat, again (second thermostat I had with the same problem). Google has no answers to  resolve the problem. As I thought, replacing it is the only way to sort it out. I hope you got it sorted too.

Community Member

Hi Nikki,

Thanks for your pointers, I have tried everything you suggested.

The unit isn't fining the thermostat, and I can't even get through the initial stages after scanning the QR code or even manually inputting the serial number.  I've even gone as far as trying to reset it by connecting it to a laptop.

I think I'll have to rethink my heating controls.  I guess it was in storage too long between moving house.

Thank you for trying to help. 

Community Specialist
Community Specialist

Hello folks,


I wanted to stop by and see how I could help.


Thanks for assisting, Mel and Nikki.


@Edaw, I'm sorry if the issue still persists, and I appreciate all the steps you've taken. I'd love to know more about this.

Could you please tell us the power readouts on your thermostat under "Technical Info" settings? Also, what other Nest devices do you have?


I'll look forward to your response.




Hello Edaw,


I wanted to see if you still needed help. Please let us know if you have any other questions or concerns.



Community Specialist
Community Specialist

Hey there,


I wanted to check in, and let you know that I will be locking the thread in 24 hours.


Best regards,


Community Member

Hi Jake,


Lock the thread if you like. The issue wasn’t resolved at all. Thanks 

Community Member

Just moved into a new home that has 2 Nest E thermostats.  The first one I was able to get set up with no issues.  When I try to add the second thermostat to the home, I get a TD023 error.  I've done a reset, and all the other possible fixes mentioned above.  Any other suggestions?