Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Camera battery charging

Community Member

My camera with battery as well as plugged in to a charger has zero battery.  I bought a second cable and tried to charge using a different outlet.  Camera is not charging and still says zero battery.  It’s only about six mo the old - 

I’d  like to get this resolved.  What am I missing?  Does the battery need to be changed or is it a defect?  Any advice is greatly appreciated.


Community Member

Solved my own issue.  Here’s how.  Checked the connector again and it appeared pins on plug were facing the wrong way.  Corrected that.  Also used a sharp object and on back of camera, pushed & held button for three seconds.  Right away my app showed camera was off.  Repeated with sharp object and held button again - BINGO.  Camera came on and now shows it’s charging.  I hope this helps someone else!

Community Specialist
Community Specialist

Hello Laurie-Tie,

We truly appreciate you posting here about what happened and for getting back to us to share the steps you've taken to resolve this issue. This'll help a lot of users who have the same concern. We can consider this one complete so let us know if you have other questions or concerns as I'll be locking this thread after 24 hours. Feel free to start a new thread and we'll be happy to help.