cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Cam Battery will not connect to network

BrendanRogers
Community Member

I have multiple Nest devices, and never had a problem with setup on my network. i have tried to setup 2x Brand new Nest Cam Battery Cameras and go through all the steps. When I get to the 'connecting' step, I keep getting an error that it can't connect. I've tried resetting my wifi, resetting the device, restarting my phone, factory resetting the camera... and absolutely nothing. 

The error keeps telling me to move it closer to other nest devices, which I have, and still nothing. I'm at my wits end. I don't know what else to try.

1 Recommended Answer

MplsCustomer
Bronze
Bronze

@BrendanRogers 

It seems like more than a few customers are having difficulty installing new Google Nest cameras and doorbells and other devices. We did NOT have the problem when we added a new Google Nest Battery Camera in September 2021, but there are over 150 replies from customers on this long thread about not being able to connect to an "assisting device":

https://www.googlenestcommunity.com/t5/Cameras-and-Doorbells/quot-Can-t-connect-to-assisting-device-...

Customers have suggested multiple solutions--some pretty disruptive and time-consuming, like removing all of their Google Nest devices--and some solutions have worked for some customers but not for others. Google Nest Support says they're still researching the issue.

The least painful solution I've seen posted, which worked for some, is to temporarily turn your installed working cameras off (in the Google Home app, by clicking "More" on the camera feed and turning the camera off at the bottom of the screen, or in the Google Nest app by turning the camera off under Settings. It seems to work for some.

Another not-so-painful suggestion is making sure Bluetooth is turned on on your mobile device. Still others have suggested putting your phone in airplane mode temporarily and then turning Bluetooth and WiFi on.

Like I said, it hasn't happened to us, so I can't recommend a solution.  I just thought I'd pass on a couple of the least-disruptive suggestions, since Google Nest Support continues to not respond.

View Recommended Answer in original post

19 REPLIES 19

MplsCustomer
Bronze
Bronze

@BrendanRogers 

It seems like more than a few customers are having difficulty installing new Google Nest cameras and doorbells and other devices. We did NOT have the problem when we added a new Google Nest Battery Camera in September 2021, but there are over 150 replies from customers on this long thread about not being able to connect to an "assisting device":

https://www.googlenestcommunity.com/t5/Cameras-and-Doorbells/quot-Can-t-connect-to-assisting-device-...

Customers have suggested multiple solutions--some pretty disruptive and time-consuming, like removing all of their Google Nest devices--and some solutions have worked for some customers but not for others. Google Nest Support says they're still researching the issue.

The least painful solution I've seen posted, which worked for some, is to temporarily turn your installed working cameras off (in the Google Home app, by clicking "More" on the camera feed and turning the camera off at the bottom of the screen, or in the Google Nest app by turning the camera off under Settings. It seems to work for some.

Another not-so-painful suggestion is making sure Bluetooth is turned on on your mobile device. Still others have suggested putting your phone in airplane mode temporarily and then turning Bluetooth and WiFi on.

Like I said, it hasn't happened to us, so I can't recommend a solution.  I just thought I'd pass on a couple of the least-disruptive suggestions, since Google Nest Support continues to not respond.

Thank you. I removed all my other nest devices, and then went through the install process again... Worked. I had to then reinstall all my other devices again. What a dumb situation.

 

Resetting the cam to factory settings solved the issue for me.

JayPostones
Community Member

Same issue here. I have a Nest doorbell, working fine, and bought a 2-pack of cameras. One of them connected fine. The second tried, and fail,s to 'connect to assisting device'. Can't find a working solution other than setting up a second 'home', which frankly is ridiculous. How is this a Google product? 

Hey. See above. I uninstalled all my other Google/nest devices and restarted the install process for the cameras. Before this, I also toggled airplane mode on/off. The cameras finally installed. I then had to go and reinstall all my other devices. Pain in the ass.

I managed to get it to work too. Brought the other camera back inside and removed it from my Google 'home' then set up the 2nd cam, re-set up the first and it seems to work. Such a stupid thing to need to do though. It's Google... it shouldn't be this crappy.

Agreed - this seems like a simple fix Google should have spotted. I imagine a lot of cameras get sent back by folks who get stuck at this step. I'd like to think I'm reasonably tech-savvy, and I was ready to give up before finding this thread.

I'm in the same boat you were, except your solution hasn't worked. Hopefully I get a response soon as to the next step. Struggling to see why this is such a difficult thing, especially coming from google

Brad
Community Specialist
Community Specialist

Hi there, 

 

I apologize for my late response and thank you for all of your patience while waiting for a reply. I definitely understand how frustrating your situation must be, and I wanted to make sure that your concern was acknowledged. I would suggest that you reach out to Support for further assistance. Click through the options once filled out, and then click next and it should give you a phone number to call, or the option to chat with support. 

 

Best Regards, 

Brad.

Hey there, 
Just wanted to hop in here to see if we still needed help on this. Please let us know if you have any other questions or concerns as I will be locking this in 24 hours. 

Have a great day. 
Garrett DS
 

Sk3tch
Community Member

None of the solutions on here have helped me. I bought a two pack of nest battery cameras and neither will connect. Says I need to move closer to camera or closer to router. Won't discover either camera. 

JamieC
Community Member

has anyone found a number to call to for help on this?

 

CNAX
Community Member

SOLUTION FOUND!!  I have literally read sooo many different tips about this problem and nothing worked. I factory reset (12 seconds till yellow light) my camera; turned airplane mode on and off; made sure I was plugging in the camera ONLY when instructed to; uninstalled and reinstalled the Google Home App. NOTHING worked. I was using my Nest Thermostat as the "assisting device" which worked for my other 3 cameras, but it would not work for this one. So, I took one of my other cameras, plugged it in and used IT as the assisting device and it finally connected! My 4th camera must have been lonely and just wanted to be by his friend. I found this solution here - thank God this guy posted this solution!  https://www.youtube.com/watch?v=fToCUbzEIp4

jg234
Community Member

Found a solution which worked for me.

I had two of the older Nest cams (one indoor and one outdoor) and migrated them over to the Google Home Account when Google suggested it.  Had no problems and was happy.  Recently I decided to buy a new Nest Cam Battery and use it outdoors.  I spent an afternoon trying to get my Google Home Account to recognize and activate the camera and had no luck.   Google Home wouldn't recognize the code or kept on wanting to set it up as a WiFi router which then went down a black hole to nowhere.  I was about ready to send the camera back but decided to see if I could get the camera to work on a brand new Google Home account.  So I set up a new Google Home account with no devices on it and lo and behold I was able to get the new camera working.  The only problem was that the Nest Aware account was integrated with the original Google Home Account on which my other cameras were working.   I would have to pay for an entire new Nest Aware subscription to get any  video history for the new camera.  I wasn't going to do that.  I slept on the problem and the next day I removed the new camera from the new Google Home Account and tried again to get it to work with the Google Home Account that had the Nest Aware subscription.  At first I got nowhere, but then I turned off all my other cameras and scanned the quorum code again (no luck) then entered the numerical setup code (no luck).  That brought me back to scanning the quorum code again which I did (no luck), then I entered the numerical setup code and lo and behold the new camera was recognized and then integrated into the Google Home Account with the Nest Aware subscription.  I then turned on all my other cameras and everything worked.   Persistence paid off.  Maybe this solution will work for others.

rsbst19
Community Member

Fix for me was to NOT turn on mic and audio during setup.  Literally went through a complete device reset ~8 times, with and without QR code.  Finally opted not to use miv and audio and boom.  it worked.  

neap
Community Member

Sti

 

 

I've tried all of the above and still not working

aatienza
Community Specialist
Community Specialist

Hey neap,

 

I’m sorry to hear you’re having trouble with this. No worries, we'll check this out. Could you tell us the exact message you're getting when you try connecting your camera to your Wi-Fi network? Are you using a dual-band router (2.4GHz and 5GHz)? If so, which band are you trying to connect your camera?

 

Check out this link on how to Troubleshoot connecting to the app during setup.

 

Thanks,

Archie

aatienza
Community Specialist
Community Specialist

Hey there,

 

I just wanted to follow up to see if you still need our help. Please let us know as we would be happy to answer any questions you may have. 
 

Thanks,

Archie

aatienza
Community Specialist
Community Specialist

Hi there,

 

Just checking in to make sure that you've seen our responses. Please let me know if you have other questions or concerns as I will be locking this in 24 hours if I won't hear back from you again. Feel free to start a new thread and we'll be happy to help.
 

Thanks,

Archie