cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Cam Indoor Unable to Join Wifi Network

zarthos
Community Member

I have a Nest Cam Indoor (Single) purchased in 2019. It has been operating without any issues until Monday when it suddenly went offline, nest app alerted me to that.

I followed the debugging guide and tried removing it from my existing Space and adding it again. I used the app on my iPhone to add it by scanning the QR code on the back. I got a C119 error message.
I then tried to add it using my laptop. I got a C309-403 error message.
In both cases, the setup process detects the device, asks me for Wifi username and password, and then throws the above error messages. I have attached screenshots.
I repeated these steps after doing the following -

1. Removing and reinstalling the Nest app on my phone.

2. Using a different Wifi router.

3. Using a mobile hotspot.

4. Powering down the Nest cam and waiting for 5 minutes before attempting to add it.

During this entire process, the light in front of the camera is blinking Blue.

I spent half a day with Google support on chat debugging this, and we repeated all the above steps with no luck.

I have checked my router and network settings. All nodes including the router are ping-able for all other nodes. No firewall or IPS is blocking any connections.

Any ideas on how to further debug this? Is my camera bricked?

1 REPLY 1

zarthos
Community Member

Error message pics attached.

iOS error messageiOS error messageLaptop error messageLaptop error message