Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

"Can't connect to assisting device"

Community Member

I purchased the Google Nest Cam 2 Pack. Installed the first one in the Google Home app with no problems whatsoever, went to go install the second one and was met with the "Can't connect to assisting device" error. Doesn't matter what I do, I cannot get past this screen. Tried an iPhone, and Android, tried turning off the dual-band wifi so everything was on 2.4ghz, tried putting the cameras beside each other, nothing works. 


2 Recommended AnswerS

Community Member

I had the same issue. I just disconnected the camera I had initially setup and then setup up the camera I was having trouble with. After that camera was good to go the second camera was able to connect. Hope this helps!

View Recommended Answer in original post

This solution worked for me as well. Same problem here. I bought 2 nest cams and a doorbell. Couldn’t install anything past the first camera.

I removed the camera from the Google Home app, installed the doorbell properly, then came back to re-install the camera.

you will still briefly see the “connecting to an assisting device” screen, but it freezes and jumps to the following one and everything works fine.

I left both charging now. God knows what’s going to happen tomorrow when I try to install the second camera.

View Recommended Answer in original post

161 REPLIES 161

Community Member

Brad I just bought a Google Nest Doorbell and ran into this same problem while trying to set it up.

There is a fully functioning Nest Hub Max on the bench top less than a meter away but the Google Home app is unable to locate or connect to it during doorbell setup. Times out with this error and offers no other option to complete the setup.

I cannot understand why it didn’t occur to anybody at Google that maybe some Nest buyers might not already have other Nest products? They do not seem to have considered this possibility at all.

How can I set this up? Or is it your recommendation that I do what others in this thread do eg return all nest products (I also have a box of 3 cameras to set up next) and write scathing reviews on every forum I can find?

This is a brand new product and just pushing everyone to technical support is utterly unacceptable for a home automation product that is supposed to work out of the box.

Community Member

Exact same problem here. Fully-functioning Nest Hub Max 2 feet from the Nest Battery doorbell, and the Google Home app is not able to connect during doorbell setup. "Try moving closer to another Nest Device". I've rebooted all devices including the phone and router. In fact, I purchased the Nest Hub Max so I can use the doorbell. Due to supply chain issues, I received the Nest Max Hub long before the doorbell, so I'm guessing I can't return it now. 😠

Community Member

I have the same issue as above people when trying to connect a nest doorbell cam and two outdoor cams. Funny thing is, they were all working fine until my Wi-Fi router failed and I needed a replacement. When I got the new router hooked up I had these issues as above trying to connect my cams. Please help. 

Community Member

Hi Brad,

I just bought a Nest Doorbell (battery) Last week. I am having the same issue everyone on this Thread is having. I am not doing the work around! I have 5 cameras outside,  a Thermostat and smoke detector. I am not removing all of those to get this Doorbell setup. If its not going to work otherwise can you let me know so I can return it? 

Community Member

I agree, I have three outdoor cameras already installed and working fine. I really don't want to risk it and remove them in order to install other cameras in hopes that the work around actually works. Google do you have an idea on when this will be fixed? I have all your other products but if this isn't fixed soon, I'll have to go to your competitors. I can't believe this forum has been going on for this long without a solution. 

I had the same issue with two nest thermostats. I had to delete the first from google home, then add the 2nd one.  The first already had an update, by removing it, the second connected and got it's update. Then I added the first back in (had to factory reset it). All working in one home.

Luckily it's just two devices.  I'm going to bet the more devices, the more you add and remove so they all get updates and then re-add.

Thank you!! Same problem, two new nest thermostats. Set up the first one and it worked fine. Went upstairs and kept getting the assisting device connection error on the second one. Did as you said and removed the first from “my home”, and then the upstairs one set up just fine. Went back downstairs and did the full factory reset on the first one (gotta tap the menu on the device and poke around a bit to find it). Then I re-added it all over again, and now we’re good to go on both.

hey google, workarounds are not solutions. That was a pretty big waste of time. 

Community Member

Thanks for the tip. To clarify, by disconnect you mean remove from the Google Home app inventory?

Yes, that did it for me.

Community Member

Have same problem.
please specify exactly what you did to “disconnect” the first camera.

Thank you

Community Member

I just removed it from the Google Home app and it worked for me.

Yes, after setting up a 1st Nest Thermostat successfully I ran into the same problem trying to setup the 2nd. After removing the  1st from the Google Home account, I was able to successfully setup the 2nd device. Then I did have to perform a Factory Reset on the 1st device to finish the setting it up again, but it was able to connect. So, now both are successfully setup under one location. My suggestion for adding more devices moving forward would be to first set them up under a new location to make the initial connection to the correct WIFI network and to receive all of the downloads. Then remove the device, delete the new location, factory reset the device and then connect it under the desired location.

if Google is listening, it would be much easier to just let us select the network we want to connect to each time in stead of using another device.

Community Member

I don't know why but this solution worked.

Thx for the info. I had a similar problem installing camera #2. 

It appears that there is an automatic download of a software update which happens with camera #1 (that’s good!) “Can Connect to Assisting Device” page appears after un-updated camera #2 is rejected by the now updated camera #1.


The work around described here is to force two separate software updates. It’s awkward, and non-intuitive, but here goes:

  1. Install your Camera #1.
  2. After installation is complete, Remove Device from the network where you just installed it!
  3. Install Camera #2.
  4. Install Camera #1. If this worked, you should quickly move pass the “looking for other devices that will help this install go quicker [paraphrasing]” screen. 

FYI, there’s one extra step I used which I don’t think makes a difference…but I’m sharing in case your results are different than mine. I created a second network for my Camera #2, then deleted it from the second network and installed it on the first network. That didn’t work…until I had deleted Camera #1. The instructions above attempt to save you these few steps.


Heads up to the holiday elves at Google? User testing matters! Not sure how you missed this situation, but it’s a big deal and it’s a big dent in the the Nest reputation if you don’t get it fixed before the holiday installations start up and the returns pile up! Let’s get on this easily fixable bug, people! :>)

Community Member

I tried the same procedure as Hancfo and it worked!    I had to open and close the app several times to get both cameras to reset.   If you get to the point where your screen says "camera off",  and you can'tsee a way to turn it back on, try closing and reopening the app one or more times.

Hey, I have the same issue as everyone else that has posted here. I did as you suggested (deleting the first  camera) and tried connecting the next but now, no matter what I do,  all i get is a 'Something went wrong' error!! Very frustrating!!! I even tried setting up the new Homes for each device and still no luck. Now I don't even have the original camera connected 😞 

Community Member

For some reason disconnecting my old camera did not help, unlike most others in this forum. However, I called google and they suggested trying to add this camera in airplane mode with WiFi and Bluetooth turned on...which finally worked. That's 2h of my life I will never get back... Hopefully will help someone else though. 

Airplane mode with Wifi and Bluetooth turned on worked for me too.

I second this solution. I was almost ready to give up with trying to connect a couple of wired and wireless cameras through the Google Home app. You absolutely need to completely disconnect your first synced camera. Then you can connect a new camera. Once the new is connected I did a factory reset on the camera I previously connected and disconnected. It then connected just fine and I was able to add two additional cameras without having to go through this process again. I did try calling google support and wasted a couple hours of my life. I have yet to hear back on my open case. Thanks for nothing Google ha ha! There is something faulty in the Google Home app when trying to connect a new camera with an existing device. Try this solution first before you get frustrated. I am so glad it works because the video quality is amazing.

Community Member

I had the Google doorbell connected first and faced the same issue - after reviewing your article I removed the doorbell and then added the nest cameras - which worked and then added the doorbell thereafter - hope this helps others

Community Member

How did u disconnect the first device? In the app? And do u have to to add the first one again after the second one is added?

That didn’t work for me

Community Member

I can't tell you how happy I was to find your solution.  This solution worked for me!  So aggravating.  Once I disconnected 1st camera, the 2nd camera set-up perfectly easy.  I then re-set-up my 1st camera and now have them both online.  Thank you again for taking the time to answer the solution question in the OP.

Community Member

Thanks!! We doing same way as u mention, works well !!

Community Member

It doesn't work for me.  Now both cameras are off and I can't add them back on.  What should I do? 

Community Member

Im no expert but, what step do you get to before seeing an error?

Community Member

I followed the forum - uninstalled my first camera and installed the second one - it works. Then I tried to add the first one back and saw an error that it couldn’t add. I uninstalled the second one hoping that I can add both on after - now both cameras don’t work. 

Community Member

Same thing happened to me. I returned the cameras. Don’t have time for this kind of BS.

Community Member

I am planning to do that. So what other brands will you recommend? 

I had this same issue and spent nearly an hour and a half agonizing over it trying anything and everything to make it work. Thank god I saw this post because I did this and got it working also. I had four devices to add to the google home app: Wireless doorbell, nest cam wireless outdoor, nest cam indoor wired, google home hub. Here's how it went down: 

1. installed doorbell easily with no issues

2. tried to add nest cam outdoor, absolutely would not work because it said it could not find another nest device to connect to. agonized over it for about 20 minutes. Decided to try the hub. 

3. Installed the hub with no issues whatsoever. 

4. Tried the outdoor cam again with no success, then tried the indoor wired cam also with no success. Agonized for an hour over it. 

5. Finally decided I was giving up but found this post in a last-ditch effort. 

6. Removed doorbell from the google home app completely (I left the hub installed) 

7. Tried the outdoor cam again, AND IT WORKED! Connected easily and quickly. Then added the indoor cam easily with no issues, did not have to remove the outdoor cam for it to work. Added the doorbell cam back again, and boom- everything is working nicely. 

Major pain in the butt and hopefully they fix this issue soon, but got there in the end. I hope this helps!

It worked. I disconnected the doorbell and then started with the two cameras. It worked. The issue with connecting device might be because of the doorbell beeing activated first and is on battery. I connected all of them to power in the living room and then started adding them in the google home app. thankfully it worked!

Shame and you google for not answering this question properly. better get that support-line of yours up to speed or start paying community members...


Community Member

This worked for my thermostats with the same problem.  The problem now, how do I add the first one back?

Community Member
  • Try to ad as new device again, should work

Community Member

I found the solution that works, is repeatable for multiple devices and makes sense.  These IoT devices, whether they are cameras, doorbells, or thermostats, all the same restriction - they don't like being on 5G networks.  Once I moved all my thermostats to 2G, they all got on the first time.  I had to reset each device for it to work though.  Would have been nice for the documentation to SAY 2G only.

Community Member

Hello, I ran into a similar issue, with error saying my doorbell cam could not connect to other nest devices. - however I did not have any other cameras. Only a nest thermostat. After many tries, I removed the nest thermostat from the google home app, installed the wired doorbell camera on the nest app no issues whatsoever, and finally had to factory reset my thermostat and add it back. A huge pain in the butt.


It appears on the google troubleshooting page it states that the only nest products that will help the doorbell set up are the smoke detector and alarm system series items. It seems the doorbell just doesn’t know this. I have had so many other issues with other google items, it really makes me wish I stuck with Apple items even though they are double the price. 

best of luck. 

Community Member

What do you mean by disconnecting? 
delete ?

Community Member

Remove device (camera) from your app, there is option to deliver camera when you open camera and press seating button, then at the bottom should be delete option in red color. Then close app on your phone, open app again and add new device, after new one set up, add previous device. It worked for my 4 cameras. Unfortunately I have to do it one by one on my iPhone, it takes extra time

Community Member

Yes- I deleted the camera from the app so had no devices at all in my Google home app. Got the camera I was having trouble with up and running and then connected the original camera. 

This works!


I have purchased 4 of these Nest Cam Indoor Wired 2nd Gen cameras and was able to setup the first camera without issues.  But when trying to setup the 2nd camera it just wouldn't setup, so tried the 3rd and 4th and still the same problems saying "Can't connect to assisting device".


Like someone else mentioned in this post if it works fine if you setup another Google Home - which I did called Test and was able to setup the camera fine!  But obviously unacceptable the whole point is to put them on one Google Home network!


So, saw Hancfo's comment about deleting the original camera that setup fine, and then add the other camera that wasn't setting up (which worked), then re-added the first camera that worked straight off.  This worked for me.

I then proceeded to setup the other 2 cameras without issues like there was never an issue in the first place!


Google you really need to sort this out!  I spent 4 hours trying to get this working and on your website it says how easy it is to set them yes, more than one no!  We shouldn't have to install one, then attempt to install the second to then have to delete the first setup camera, then setup the one that didn't work, then setup the original to get these working!  This is one major bug!!


I had the exact same thought. My (failed) approach was to deleted the insipid Google Home App, unplug both cameras, then freshly install the home app and add the second camera - the one I could not add - as the first one. But the freshly installed app retained the first one (the one I had no trouble setting up). 

I've spent hours on this too. Scoured the web for hours; watched YouTube videos... didn't waste much time on the Google Nest Support Site because corporate help sites are rarely actually helpful. 

Just bought these at Costco and planned to return the second one tomorrow. Will try Hancfo's method of deletion of the specific camera in the app itself and re-post if I find success. 

Only posting now to let Google know that they have a problem. And I don't blame Nest I blame their incompetent corporate overlord. And what really irritates me most is that the app is effectively trying to "own" all of my connected home devices. Listen Google, you might have successfully dominated the world but you've failed at your attempt to dominate my home. And all I wanted was two cameras in my house.