cancel
Showing results for 
Search instead for 
Did you mean: 

Cant communicate with chromecast after changing hub

StevieG
Community Member

Got a new hub, can't set up chromecast. Getting a message saying the Home app can't communicate with the CC. CC still trying to connect with old hub. Tried a reboot by disconnecting from power as the CC tile is not on Home app anymore.

1 ACCEPTED SOLUTION

davidking
Gold Product Expert
Gold Product Expert

If you've already changed to a different Wi-Fi network, try these steps:

  1. Open the Google Home app.
  2. At the top left, tap Add + > Set up device > New device > set up new devices in your home.
  3. Follow the in-app steps.

If these steps above don’t solve the issue, you’ll need to factory reset your Chromecast, then set it up again using your new Wi-Fi network and password. If you're using Chromecast with Google TV, follow these setup steps instead.

Instead of factory resetting your Chromecast, if you're comfortable changing your router settings, you can change your new Wi-Fi network name and password in your router's settings to be the same as the previous ones. Your device should then automatically connect to the Wi-Fi.

View solution in original post

4 REPLIES 4

davidking
Gold Product Expert
Gold Product Expert

If you've already changed to a different Wi-Fi network, try these steps:

  1. Open the Google Home app.
  2. At the top left, tap Add + > Set up device > New device > set up new devices in your home.
  3. Follow the in-app steps.

If these steps above don’t solve the issue, you’ll need to factory reset your Chromecast, then set it up again using your new Wi-Fi network and password. If you're using Chromecast with Google TV, follow these setup steps instead.

Instead of factory resetting your Chromecast, if you're comfortable changing your router settings, you can change your new Wi-Fi network name and password in your router's settings to be the same as the previous ones. Your device should then automatically connect to the Wi-Fi.

JenniferV
Community Specialist
Community Specialist

Hey there,

 

Thanks for the help, davidking.

 

StevieG, how's it going? Were you able to connect your Chromecast to your new network?

 

Thanks,

Jennifer

StevieG
Community Member

Hi, yes I got the issue resolved. I had to do a factory reset of the device. All's good now. Thanks fir the help. 

Jeran
Community Specialist
Community Specialist

Hey there!

It looks like StevieG was able to resolve the issue, so I'm locking up the thread. As always, feel free to make a new thread if you have any more questions or concerns.

Thank you for your help, David and Jennifer!

Best regards,
Jeran