Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can't set up activity zones—"couldn't turn on"

Community Member

Got a brand new Nest Doorbell Gen 2 (Wired) and I can't set up an activty zone. When I click "Add a zone" in the Google Home app, the spinner spins, and spins, and spins... And then tells me "Couldn't turn on". A button allows me to try to "Open camera", which the app then does great, with no issue at all. Trying the whole loop to add a zone brings me to the same problem.

I have a Nest Aware subscription so it should work. I tried deleting the camera and adding it again and it didn't fix the issue. 




Google Nest says this defect is known to them. They've merged several previous posts into this 50-reply post:

For us, over the last couple of weeks, we get this "Couldn't turn on" error on some days but not on others, when trying to access Notifications, Activity Zones, and Seen Events. It was working again yesterday and so far is working today.  Since our camera is always on and "Live", and since we can immediately return to our camera's live feed, it's not clear what couldn't be turned on.  I've logged "Feedback" numerous times when it occurs.

I'm just another Google Nest customer, but my theory is that--since it is intermittent--it's some sort of problem or bottleneck that's occurring on Google Nest's servers that manifests itself in this cryptic "Couldn't turn on" error message.

Community Specialist
Community Specialist

Hello everyone,


@isacriedpwr, thanks for reaching out here in the Community. How's it going? Were you able to try it again? Try reinstalling your Google Home app and make sure you have the latest version. You may also try restarting your Nest Camera and let us know how it goes.


I appreciate the help, MplsCustomer.




I've tried all those steps and it still isn't working...

Community Specialist
Community Specialist

Hi folks,


@isacriedpwr, chiming in—here are some troubleshooting steps you may attempt if you're having issues setting up an activity zone for your brand-new Nest Doorbell Gen 2 (wired) and getting the "couldn't turn on" error in the Google Home app. You may skip the steps you already took.


  1. Confirm that your Nest Aware subscription is active and associated with the correct Nest Doorbell. You can verify this in the Nest app by going to the camera settings and checking the subscription status.
    • From the Nest app, tap Settings. 
      • If you have multiple homes, be sure to select the right home and camera.
    • Tap Nest Aware.
  2. Make sure your device is running the most recent version of the Google Home app.
    • Open the Google Home app.
    • Select a Google Home device.
    • Select the 'Device information' option.
    • Scroll to the bottom, where you'll see the current firmware.
  3. Try clearing the cache and data of the Google Home app. This can help resolve any temporary glitches or conflicts. Go to your device's settings, find the Google Home app in the app settings, and choose the options to clear cache and data.
  4. Verify if your phone or other gadget is connected to the internet steadily. For activity zone configuration to work, communication with the Nest servers necessitates a stable connection. Make sure your mobile data connection is steady or that you are linked to a robust Wi-Fi network.
  5. If possible, use a different device to set up the activity zone, like a tablet or another smartphone. This can assist in figuring out whether the problem is unique to your gadget or whether there is network issue.


Let us know how it goes.





Doesn't Google Nest share information--such as known defects--with its staff?

This is a known defect. For the last several weeks, if we try to access Notifications, or Seen events, or Activity Zones, we get the "Couldn't turn on" error message. Some days it works; some days it does not.

Our battery camera is on and live at all times. We get the error when coming from the livestream view and selecting one of those options. We can return to the livestream right after getting the error.

Multiple other customers have been reporting the same thing.

So, it certainly seems something is malfunctioning on Google Nest's servers.

I have left Feedback at least a dozen times.

Screenshot 2023-11-13 at 2.15.51 PM.jpeg

Community Specialist
Community Specialist

Hi everyone, 

I’m sorry for the delayed response. We rolled out a new software update on the Google Home App last week in Android and IOs. Please let us know if the issue persists after updating your Google Home app to 3.9. 

Thanks for the help, @Zoe and @Emerson.


Community Member

This is still an issue of today with the latest updates. 

Community Specialist
Community Specialist

Hello leegle,


Thanks for reaching out here in the Community. To confirm, what is the make and model of your mobile phone? What is the software version of your Google Home app? 


To check the app software version (In case you have an iPhone):

Go to Settings> General> iPhone Storage> select the Google Home app> see the software version below the Google Home app.


Let us know your update here.




Community Member

Still an issue as of today. Has been for a long time and no amount of updating and restarting is fixing it.