Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Dead Thermostat E straight out of the box

Community Member


I'm setting up my Thermostat E and after plugging the base unit in for the first time am getting the error TD023 on the app. The base unit appears to be totally dead: no lights, no response to pressing the ring.  I'm trying to follow the instructions for a reset, but it seems the unit needs to be on in order to do a reset!


Community Member

That happened with the Nest thermostat I bought from Lowes.  I took it back and they let me replace it immediately.  The second one worked.

Community Member

Thanks Bry.  The base unit's battery was totally flat.  The Nest helpdesk guy showed me how to "force charge" it via the USB port on the back.  I think this can happen when units spend extended periods "on the shelf" between factory and end user.  I managed to get it to take a charge, but it remains to be seen whether being totally discharged for such a long period has damaged it  permanently.  Interestingly, the retailer where I bought it had about a dozen units on the shelf, every one of which had been opened (perhaps bought, tried without success, and returned?)

Community Member

I know it’s been awhile but do you remember how to force the nest thermostat e to charge via USB? I also have a dead one but bought brand new from an individual so I can’t take it back.