cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Gen 3 Heatlink Power Loss

killultagh
Community Member

Hello,

As of this evening I have lost the capability to heat my home nor water. The Heatlink appears not to be receiving power after 3 years of experiencing no issues.

 

Error message on thermostat is h72.

 

There are no lights on the heatlink. No lights when button is held in for 10 seconds either.

 

The boiler does not activate when pressing the heatlink button.

 


No recent power cuts.

 

I have checked the breaker switch and the fuse box and everything is ok.

 

Tried to turn the breaker switch on and off. Still no change.

 

Please advise as this appears to be a common issue among customers.

 

Thanks

2 REPLIES 2

Spawned
Community Member

Insert usb cable into heat link and connect to wall charger. If it powers up, your heat link is dead. To be more specific, the diode on the PCB is gone. Seek a replacement after the test. Contact Google.

Replacement heat link being provided as this is a known fault I’m assuming.