cancel
Showing results for 
Search instead for 
Did you mean: 

Nest heat link died

Xiao
Community Member

Our nest learning thermostat was working but it stopped working now - the heat link is not working. Tried to ring to get some technical support but nowhere to start, appreciate if anyone can help or offer some advice please?

 Many Thanks,

xiao

12 REPLIES 12

CaptainJeff
Community Member

You won't get any help out of them.  I have a similar issue and just posted about it.  23 days and counting.  The google nest group will treat you like a child and then escalate it to another person who will ask you to do all the same things.  beware of Enzo, Madison and Caitlin.  Their job is to push you along the endless troubleshooting path until you finally go away.  Ditch the product.  

Xiao
Community Member

Thanks so much for your reply and It’s so frustrating as  the technical support is so bad, plus the kit is not cheap but it didn’t last long as only had it for about 2 years. Did you get a new one? How did you fix it? 

CristianC
Community Specialist
Community Specialist

Hello again. Just checking in. How's it going with your Heat Link?

CristianC
Community Specialist
Community Specialist

It's been a while since this thread was last updated so I'll go ahead and lock this thread. If you're still experiencing problems, please feel free to start a new thread and we'll be happy to help.

CaptainJeff
Community Member

Still working with them, but I will need to replace the thermostat tonight or I won't have heat.  Since I wasn't at the thermostat, they wouldn't tell me what troubleshooting actions they wanted to me take.  They treat people like idiots.  I felt foolish thinking replacing the baseplate would fix the problem.  I refuse to be treated like an idiot again.  

Kat2
Community Member

My Heatlink has just stopped working - it appears there is no power going to it!  In December it would have been installed for 2 years!  There has also been times with problems connecting to the Wifi.  My initial nest thermostat had to be replaced due to a software glitch - if this has now given up (meaning I assume they would need to send me a new Heatlink) it would be the third nest component in less than 2 years.  I've decided to dump this and get someone to come and install a new thermostat!  Good luck to anyone pursuing and trying to fix their issues. K

CaptainJeff
Community Member

It's frustrating and disappointing.  They make you feel like you're the only one experiencing the issue, instead of saying "yes, we are seeing that problem occur....".   A Tech Support Rep won't last long if they go off script and are truthful about a problem.  Google is as FOS as Facebook - I mean Merch, or whatever new name they made up.

I m facing N72 error since last month but no help from Google. I have tried all available options on net .. nothing working. 

I'm still thinking that with all of the people complaining of the same issue on a thermostat that worked before and specifically heat is not working this heating season that they updated some firmware on the thermostat which is causing this issue.  specifically with a heat system, it's very basic.  Typically 2 wires in a normal open circuit and the thermostat closes the circuit to call for heat.  To test your system wiring, you can put connect Rh to W and it should cause your heat to come on. 

CaptainJeff
Community Member

My heating contractor did that and system started.   The problem is with the multi system thermostat (Learning variant).  My 4 Nest E (heating only) have been flawless.  I even used a Nest E on this location during last winter before making decision to install AC C wire and shift to Nest Learning.  Why it first works and then doesn’t is a mystery.  

I have 2 x 3rd Gen learning and 1 Nest E.  The learning ones were added when I upgraded my A/C to a 2-stage system a year ago.  So my other learning thermostat only drives my A/C.  I have swapped displays and the other one doesn't work either which again leads me to believe that it was a firmware update to both.  Wish there was a way to downgrade to the previous version and try it out.

CristianC
Community Specialist
Community Specialist

Hello everyone,

Thanks for reaching out. I'll do my best to get this sorted for you as soon as possible.

Here are some helpful troubleshooting steps:

Press the button on the Heat Link and check if you have any lights on it
Check if the circuit breakers and the switches are set to on
Turn them off and then back on
Press on the button again and check for LEDs

Could you also help me with some answers to these questions?

How long has your thermostat been installed for?
Did the issue happen during the installation?
Is there any error on the Nest thermostat display?
Have you had any power cuts recently?
Have you had any work done on your electrical or heating systems recently?
If yes, was the power properly restored at the fuse board after work was done?
How many zones ( thermostats ) are present in the setup?


Regards,
Cristian