Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest heat link no lights

Community Member

Our heatlink doesn’t seem to be working. There are no lights at all so resetting doesn’t work. We’ve tried all the troubleshooting suggestions and nothing, any ideas on how we sort this out? 


Community Member

I just met the same problem today. H71 error. Heat link doesn’t show any light. Press 10s, 20s, 30s no any reaction. Anyone could help?

Community Specialist
Community Specialist

Hi @Chris0188 and @swords3! I'm so sorry to hear about this situation, but no worries, we'll sort this out. Please answer the following questions:


1. When was the thermostat installed?
2. Are you seeing any wiring reports or errors on the thermostat and/or the app? 
3. Have you recently had service or maintenance on your electrical, plumbing, or heating system? 
4. Were there any power outages?
5. Have you tried any troubleshooting steps before contacting us?


Also please try to turn your power off and then back on from the fuse board and check after that if the Heat Link has any lights on it. 

Community Specialist
Community Specialist

Hello there @Chris0188  and @swords3 ! Just checking in, did you see my colleagues previous message?