Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest not heating

Community Member

Unit worked fine for 2 years. Now glows orange but no signal being sent to furnace. 2 other zones on our same furnace with non nest thermostats work fine. I'm feeling its the firmware update as some others have mentioned but Google help won't acknowledge that is the issue.  Anyone in Community able to help since Google won't acknowledge the problem?



You first need to make sure that your thermostat is not defective. Turn off power to your furnace, then join together the Rh and W wires (take them out of the nest wire plate and join them with a small wire nut or just twist them together), power back your furnace and check if your zone is working properly. 

Good point; I re-installed the original non nest thermostat and it works fine

Ok so this could be either a software or hardware issue, more likely a hardware issue. You could try to reset it and see if that resolves the issue. If not, I would call google support and discuss a potential replacement unit with them. Not sure which Nest model you have but in my experience 6.2-22 software version on the Nest learning third gen works fine and 1.1-9 on the Nest 2020 also does not seem to have any issues (the one with the mirrored backplate). 

Community Member

Thanks. I've spent last 65 minutes with chat support. You and I seem to be the only ones thinking its a hardware issue.  They keep putting me through same steps as already done with previous support calls (remove Rh and try, Remove C and try) etc. etc.


it is the 6.2-22 software. If I do full reset does it go back to a previous software/firmware?


You can’t revert easily to a previous firmware but try to reset it, you can do a full reset from the Nest device menu.

Also before resetting it, try to restart it and see if that helps. Press down for 10 secs to restart. 

Same situation. I have two nests...both stopped heating properly with 6.6-22.  Old thermostats work perfectly, so it's not the system. 

I've reset, rebooted, swapped locations....nothing. I have to fight with it to turn in and when it does come on its a short cycle and never teachers the temp. 

Hi Elswann, I assume you mean the 6.2-22 software? 6.6-22 is not available. If you tried to remove the Nest from your Nest app and do a factory reset so that it is a clean install as if it was new and that didn’t resolve the issue, try restarting your router to ensure it’s not some strange connectivity issue confusing the Nest. 

Correct 6.2-22  

Hi there I have two devices as well running 6.2.22 and I am having the exact same issue with it not hearing correctly. Has this issue been resolved? We have tried to reset, restart, etc and nothing seems to fix it. Is there a way to revert to previous version?

Community Member

Not that I've found. Fortunately, where I am it's been hot-- I can tell you the AC works perfectly still. Had to turn it on today. 

As long as the weather holds....I'll just wait out an update. If we turn cold soon-- I'll have to switch to another brand. Maybe even grab the cheap digital Amazon ones.

I have the same issue. Installed two years ago and now randomly stops working. My house is currently 64 F and I am freezing. I Know it's not the furnace, that works fine, it's the Nest. Tomorrow I am buying a normal thermometer and throwing this piece of crap in the garbage where it belongs. 

We are having the same problem. Have you found a solution? 

Yes. My solution was to remove the Nest, and install and Ecobee Premium. I couldn't be happier. Its use of sensors is much more refined and configurable than Nest's. And the Ecobee just works - integrates with everything - Google, Apple Home, Siri, Alexa.

Community Member

I did the restart as one of the first steps. Didn't work

Ok. Suggest you do the reset, there could be some configs messing things up cross versions. 

ITS NOT A CONNECTIVITY ISSUE!!! The **bleep** thing just doesn't work any more. Have done all the fixes including removing the thermostat via the app and reinstalling. Restarting, plugging it into a charger, etc. etc. etc.  Google should be ashamed of themselves. I breed pedigree cats and kittens cannot regulate their body temperatures. I have them all in my bed under my duvet and two blankets and it's still freezing!!! Is Google going to pay my vet bills??

Community Member

Also another good suggestion on your part. Their support never mentioned that.


Community Member

Try turning off the safety temperature. Seems to have worked for a lot of people on this thread.

Google absolutely sucks for doing this and for refusing to acknowledge it is an issue.

Community Member

Turning off safety temperature indeed fixed my nest, thanks so much 

Community Member

Got a new Nest Learning v. 3rd gen last summer. Earlier this week, it failed with the dreaded error - can't connect to WiFi, and no networks detected. Google swapped it out and sent me a new unit (no backplate, just the CPU). I installed it yesterday. Update firmware to 6-2-27. Everything checks out, tests were successful.

This morning, 5:00a.m., schedule calls for temp to go from 65°F to 70°F. Nest was orange, fan (air handler) was blowing cold air, but my Trane status LED's indicated that no heat was being called for.

I reset the Trane (powered off, then on), rebooted thermostat, and it heated normally.

Suggestions anyone? Very annoying, to say the least.

P.S. I've turned off the safety temps to see if this resolved the issue.

Community Member

Just wanted to add my 2 cents here -- having similar issue as Greg02134.  Have an old Nest gen 1 thermostat that worked fine for years.  When heat is turned on, the Nest and Nest App (also tried the Google Home app) all turn orange/indicate heat is on, but the status LED on our Rheem system just indicates fan-only and the furnace never gets switched on.  Double/triple/quadruple checked wiring, etc., all looks good.  Bypassing the thermostat by wiring red/white directly (after taking proper precautions, of course 😉 ), and the furnace fires up as expected.

Couple of important notes:

* As noted, it's a gen 1 Nest, I guess no longer being updated; last update Sep 24, 2019, v5.9.4-5 ... Not opposed to upgrading to a newer model at all, but would sure like to know if that'd fix my issue.

* We have a brand new Rheem system.  This past spring, our 22-year old Carrier system bit the dust and we had it replaced.  Did a ton of troubleshooting on the new Rheem this past weekend before realizing the issue wasn't with the system but appeared to be with the thermostat instead.  Is there some kind of signal change newer furnaces look for to activate?

Same issue here. Started 11/10. Was also having trouble with Nest app and WiFi connection. Google replaced the unit. WiFi and app connection working but still having problem with thermostat saying it’s heating with no furnace action.

Can you check your furnace for an error condition? There are two possibilities:

  • Furnace failed to ignite. There would be an error indicated somewhere on the furnace. My Trane flashes an error code when it fails to ignite after 3 tries.
  • It's the Nest. LEDs on the furnace are on standby (for my Trane, slow green blink, one red blink every 20 secs) while the Nest says it's calling for heat.

I had both of these issues, which made it really difficult to diagnose.

I’m pretty sure my furnace is working fine. I powered down and connected the Rh and W with a wire nut. When furnace was powered on it started up and heated with no issues.

Haven’t had any similar issues of the thermostat saying it’s heating with no activity for ~24 hours. Here’s to wishing. 🤞

That's a good report. Frankly, I'm getting to the point where I am seriously considering another brand of smart thermostat. There are clearly some firmware issues that at the very least, are inconvenient, and at worst, could potentially cause damage.

Update: Google processed a manufacturer replacement of the head unit. Solved the WiFi issues but furnace intermittent issues continued.  I returned the Nest fully and got an ecobee. 
Every HVAC tech that came to my home said that Nests have been known to mess with the control board and strongly suggested I replace the Nest before considering parts replacement on the furnace.  I bought and installed the ecobee myself, so no up sell motivation for the HVAC company. 

Ecobee is working for me too

I has a similar issue s many with Rh and arc jumper Ed and the Nest would not run furnace only fan.  Based on a few other posts, I was able to confirm the heat will run in Emergency mode. This lead me down that path that Nest thought I had a heat pump instead of a forced air furnace. 

I went into the menu on the app for settings and then thermostat. Under equipment it shows a heat pump with electric fuel backup.   I could not change anything, but under wiring I was able to see I had an Orange wire connected as was before but no signal on that line. I removed that wire from inside the app (left it connected) and this opened up the equipment menu, I was able to move myself to Gas force air furnace and all is well.

I want to thank CoolingWizard on to pointing me at the more advanced menu and on a few others about heat pumps.


So the basics were it was over 40 outside and Nest figured the heat pump would catch up so no auxiliary heating tried. Which is the no signal for heat to the furnace that everyone was seeing. Had it been colder it might have worked. Putting into emergency mode (and getting the cost warning) definitely pointed at heat pump.


The fact that Next guesses what you have based on wiring with no confirmation and little documentation on how to find and change it is frustrating, I feel for those that have been stuck on this forum and waiting,  I hope the app menu will be enlightening for others.

Community Member

It was a difficult issue for me to troubleshoot as well. I had two issues with overlapping symptoms. One issue was low gas pressure to the furnace. So the first of the four burners would ignite, but the flame wouldn't spread to the other three to hit the flame detector. After three tries, the furnace would shutdown for failed ignition.

I was only able to isolate this problem after we'd solved the pressure issue. Assuming it receives the correct signal, my furnace ignites first try, every time.

This problem seems to occur when the schedule shifts from "Night" (65°F) to "Day" (70°F).

One thing to try that I picked up from another post was to turn off the "Safety" temperatures. Those are the ambient temps, low and high, that if reached, will cause either heating or cooling (as appropriate) to kick in, regardless of whether or not the thermostat on.

This morning, the furnace fired up at 5:00 a.m. without a problem. I'll update here if I'm able to gather any further information.

Community Member

Figured I'd follow up here. This may be just some weird issue with my Nest, but hopefully it will help someone out.

So, I did end up getting heat to work again with the Nest, though only by using a workaround I wasn't thrilled about. I ended up just going with a new thermostat from a different manufacturer after some research (don't know if it's proper to mention the name on here, but it starts with "Ecobee") and everything works as expected with that, no strange workarounds.

To get straight to the workaround I used -- I ended up wiring the white (heat) wire to the green (fan) connector in the Nest. While this worked, it also meant the heat activated when I switched the Nest to "fan-only" mode as well. I still have no idea why the Nest thermostat was sending the "Heat" signal only through the fan connector, but that's what it appears to have been doing. I couldn't get anything out the the W1 or W2 connections no matter what mode I tried on the Nest.

Some background notes -- I did try turning off safety temps and doing a factory reset of the Nest. Neither of those worked. Also, no errors ever showed on my furnace. It's a weird issue, but I think I've spent as much time as I'm going to on it. 😄

I'm starting to think in the same direction. My HVAC guy (Nest certified, etc.) said that in his view, Nest quality has declined since being acquired by Gle.

Another problem of a different sort that I experienced: My Nest (new last summer) stopped connecting to WiFi. It had completely lost the ability to connect to any WiFi. When I went to the WiFi settings, I saw an error code, I called Google-Nest support, and they sent me a new CPU (no back plate).

It's been a lot of trouble for a device that's supposed to be trouble-free.

My tenants just advised me of a heating problem. It's winter with -2 C outside, barely keeping around 18 C in the apartment.

I have a forced air HVAC heated by hot water coming from a gaz water heater. Water heater runs fine and HVAC fan runs fine too (it's internally wired to be always on) but I noticed hot water is not circulating at all when calling for heat. I suspected the pump so a HVAC tech is scheduled for tomorrow. Never had any problem since the Nest has been installed 5 years ago, so it's definitely not a setup/wiring issue.

Now that I've found multiple complaints about firmware 6.2, I'm suspecting my Nest 3rd Gen to be the cause, updated to 6.2-27 on May 2022. I already tried turning off all auto-settings, eco temp, safety temp, schedules, etc. Depending on the diagnosis from the tech, next thing I'll try will be a manual restart and maybe wiring W1/Heat directly into G/Fan... Otherwise I'm at a point to just go get an Ecobee considering this issue seems completely ignored...

Well, an increasing number of people seem to be moving in that same direction. I have an Ecobee on order. Before I bring my tech out yet again, I'll see if swapping the Nest for an Ecobee solves this bizarre issue which, as you note, Google has yet to acknowledge.

So the HVAC tech came and resolved the problem within 15 minutes. HVAC had no problem at all. This was a Nest issue.

He made two changes. Apparently my system heat source is more considered "electric" than "gaz" type so he changed that (although it never caused any issue before whatsoever).

He also said he went in the programming and saw that W1 was marked as "needing verification" (never saw that and don't know exactly where, maybe in the Pro settings...). He made a confirmation and heat started.

As I didn't change setup since 5 years ago and had no apparent issue since then... And the fact that I was updated to 6.2 during summer and started notincing heat issues now that the outside temp is dropping... Everything's pointing to a firmware update issue.

So I keep my fingers crossed and would advise to check in the device settings for any mention of a specific wire needing a confirmation.

Let's just say that the way Google is completely ignoring the possibility of a firmware issue is making me think twice about my next purchases...

Nest CS did nothing for me. Bought the new Ecobee and have no problems.