cancel
Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Temperature Sensor Associated to Another account

BarnesBears
Community Member

I have 3 temperature sensors that were connected to our Gen 3 learning thermostat.   Tonight we finally did the migration to a google account.  The migration did not go well, and we ended up deleting the old account / device and re-adding from scratch.

Once the Thermostat was re-added I have been unable to re-add the temperature sensors.   When we try to do so, after scanning the QR code the app reply's with a message stating that the senor is associated with another account.  

I have removed the batteries from the sensors and left it our for an hours, but nothing seems to have changed.  Do I need to wait longer? Is there something else I can try (I no longer have access to the orignal account as it was deleted earlier tonight.  

7 REPLIES 7

HVAC
Bronze
Bronze

Normally you don’t need to delete the account but the connected items first. Try reactivating the account if possible and uninstalling / deleting all sensors and thermostats then try connect to new nest. Good luck 

BarnesBears
Community Member

I tried adding the sensors back this morning, and they all worked.  I guess it just took some time for the old association to clear out.

 

Hello folks,

I wanted to ensure that everything was covered here.

Thanks for your help here, @HVAC.

@BarnesBears, I appreciate your update, and I'm glad to hear that you were able to reconnect them again. For your future reference, to perform a full reset on the Nest Temperature Sensor, remove the battery for 5 minutes and then put it back. Once done, pair the sensor back with your account. So feel free to create a new thread for any other inquiries in the future.

Regards,
Mark

I am having the same issue. I've migrated to google and had to start from scratch by resetting the Nest thermostat to factory settings to get it to add to my new google account. It has been over two hours since I took the batteries out of the temperature sensors but when I try to reconnect any of them it keeps saying it is associated with another account.

Markjosephp
Community Specialist
Community Specialist

Hi RGobantes3,

Thanks for posting, and I appreciate you taking the steps above. Please make sure that the temperature sensors are no longer linked to the Nest app. Check the app, remove them, and attempt to restart the Nest Temperature Sensors again by removing their batteries for at least 3-5 minutes. Also, before attempting to add them, move all the temperature sensors close to the Nest Thermostat you're going to link.

Keep me posted on how it goes.

Regards,
Mark

It all started after I migrated to Google. The thermostat would not connect to the migrated account saying the same thing that it is associated with another account. Since the thermostat has a factory reset, I used that option and was able to connect the thermostat to the new account.

After the thermostat was connected to the migrated account, the temperature sensors were gone in the app. That is when I tried using the app to reconnect the sensors to the thermostat, but they were not connecting. App was saying they were associated with another account. After 24 hours of battery being out, sensors were still not connecting. Google Nest online help chat was not able to help. There were several suggestions and the last suggestion was to delete the app and reinstall, but none of the suggestions worked.  I stopped trying after the online help chat and kept the batteries out of the sensors.

On reddit, a commenter on a thread about the same issue posted that he was having the same issue but all of the sudden his sensors worked after three days. So I tried again after three days (from the migration date) and the temperature sensors were able to reconnect to the thermostat. I don't know why it takes three days to get the sensors to reconnect.

Markjosephp
Community Specialist
Community Specialist

Hey there,

Got it! Thanks for updating us on your efforts to address your concern and find a fix. I understand that it shouldn't take 3 days to successfully reset the Nest Temperature Sensor. We'll take it as an opportunity to improve. So, please let our product team know by sharing feedback about Google Nest.

Let me know if you need anything from me, but you can always start a new thread if you have any other questions or concerns in the future.

Best regards,
Mark