Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Cannot connect devices on Switch after a Nest Wifi Pro

Community Member

Hi everyone,

I'm trying to created a mesh wifi with 2 Google Nest Wifi Pro, which is working fine.

Problem is: I need to add some devices (domotic box, philips hue bridge, ...) to the network through ethernet, so I'm trying to add a switch to the network: 


I tried the two following configurations without any success (=> means "ethernet connection")


Configuration 1

Modem => Nest Wifi Pro Router => Nest Wifi pro additional point => Switch => Device A

                                                                                                                                                => Device B


Configuration 2

Modem => Nest Wifi Pro Router => Switch => Nest Wifi Pro additional point

                                                                                 => Device A

                                                                                 => Device B


I tried in both cases with an old Switch I had around, and a new TP-link LS105G (which is unmanaged, right?), but same result.

In the 2 configurations, both Nest Wifi Pro (the router and the additional points) are working perfectly, and I can use Wifi to access the internet. But any devices connected to the Switch cannot get out


Am I missing something? The 2 configurations looks like to be supported: 


Community Member

In configuration #2, does the switch have a dedicated 'uplink' port?  If so, make sure that cable to the Nest WiFi Pro Router is plugged into it.

Thank you for your answer, unfortunately from what I see and read, the TP-Link LS105G does not have an uplink port but instead rely on auto-uplink
I tried regardless to plug the Nest Wifi pro router into all different ports, but result is the same 😞 

Community Specialist
Community Specialist

Hello everyone, 

@BLewis, I appreciate you trying to help here.

@Daemetrius, thanks for reaching out. It looks like both network setups are great and should have worked out. How about you check the Ethernet cable that you're using for your switch and make sure it's giving out a connection? I'll also check for other suggestions from our senior specalist team.

Let me know how it goes.

Best regards,