Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google Support Recommends iOS vs Android

Community Member

I purchased Google Nest Wifi routers + APs / smart speakers for my home mesh network. Everything seemed to be going well except that with the final 2 nodes, the Google Home app would not complete the mesh test. All nodes and connected devices show good connectivity and wifi+internet speeds...but the mesh test always fails (I've been trying for 10 days or so).  I opened a support case with Google and they went through the usual (reset, etc). No luck. They said they would be in touch. 2 days later they wrote me an email saying they recommend I buy an iOS device because there's an issue with the Google Home app on Android.  That's right, the official line from google is that if you want to get your product to work, buy from the competition. They won't reopen the ticket or offer any further assistance.  Dumbest thing I've ever heard / among the worst customer support experiences I've had.


If anyone has any USEFUL ideas on why the mesh test keeps failing, I would welcome the suggestions. In the meantime, my advice to any prospective buyers out there would be buy something other than Google.


Community Specialist
Community Specialist

Hi BvR8,


That certainly isn’t the experience we want you to have and thank you for doing the troubleshooting steps. A few questions: is the mesh test issue happening during the setup or when you’re doing a mesh test after a successful setup? How far are the two Nest Wifi points from your Nest Wifi router? It helps a lot if you move them closer to your router and then do the mesh test.


Also, could you send here the case number they provided for us to review?


For more information about mesh test, see this helpful guide: Test mesh connection


Keep us posted.




Community Member

Case ID 1-1304000034813

During setup I started with the router, and then proceeded to the wireless nodes.  I was able to complete a successful mesh test while setting up the first node, but no additional nodes.  The first node is in the adjacent room (this completed a successful test), the 2nd node is in the room directly above the router.  It shows a strong connection. I was also unable to complete a mesh test on additional wifi nodes which were placed at appropriate distances and necessary got good coverage given the size of the residence in question.


As additional background. I have setup Google Nest Wifi networks on 5 different houses for friends and family. I previously had a google mesh network running without issue at this residence.  The local ISP move the lines underground so the line now enters from the basement wall vs 2nd story off the pole. The internet connection is solid / not the issue, but I needed to swap the router with a wifi node to connect to the ISP modem.  It doesn't make sense that everything was fine before but I can no longer complete the mesh tests despite factory resetting every device.  The failure of the mesh test is also resulting in weak connection to the furthest node. This node was previously connected through another wifi node because a strong connection to the wifi middle node was better than a weak / spotty connection to the primary router.


Please advise. All insights and ideas are helpful but please do realize this isn't my first setup. My biggest complaint is being sent to iOS and that Google insists we use their app vs just allowing browser access to the GUI like every other device on the planet. If Google cant maintain / code a decent app (evidently they cant) maybe they need to give users more options to connect and configure!

Community Member

Factor reset the entire network again. Still cannot complete mesh test. Terrible software and terrible support Google.

Community Specialist
Community Specialist

Hello everyone,

Sorry for this experience. Our team will be rolling out a firmware update for the Google Nest Wifi router and points for bug fixes and performance improvements. This update may take several weeks to complete, so kindly bear with us. We hope this resolves the issue that you're having with your devices. Please see the new firmware:

  • Nest Wifi router: 14150.882.9
  • Nest Wifi point: 1.56.368671

If you already got the new firmware but your issue persists, let me know.


Community Member

Thank you, BvR8. I thought I was going crazy. I have had to factory reset my network (not just the router) at minimum every two months. Two days ago I reset it as it would not even show up on my Android phone or iPad. I just happened on the iOS app a few months ago whey my Android app would "see" the points but would give me a connection error any time I clicked on "settings." I never considered the iPAD would work more reliably.  Once up again, two days ago, I could do most maintenance and setting work from the iPAD but not the Android app. I had to reset it again yesterday because it all went down again. For about two hours everything worked great. The Android and iOS apps both worked fine. I could "see" all of the points I could access settings. All worked for about two hours. For the next eight hours I had internet only to devices which were directly plugged into the points - so I know the router was connected and communicating. None of my devices would, however connect on WiFi even though they did "see" the network. My wife could watch Netflix two points away but I could not access the internet on any device. Interestingly, a hardwired connection to the router would not give an internet connection but the points did. Neither app could recognize or control the network. About eight hours later, I got WiFi back, my hardwired PC still would not get internet until connected to the now working WiFi and then switched back to a hard wired connection. This was at 02:30. While everything seemed to work, video on a Roku or Firestick showed lag. Not my usual Google Fiber experience. It is now 11:07 and everything works except the android app, once again can "see" the points but has a "cannot connect" icon when I click the "settings" button. The iOS version can adjust settings. I did not do anything between 02:30 and now.  I'm back to where I was three days ago.  It all works (except the Android app) and I'm not going to touch it.

Is there a GUI that I can use to bypass the app?

When it works, it works well. When it doesn't work, it is a real time consuming pain. 

PS - I have a Pi-Hole setup. Does that make a difference? I'm guessing no as the whole thing will work fine for two months and then suddenly go which is the same pattern as before I got the Pi-Hole. 

PPS - Why the cartoon characters in the app? They take up space that could be used for buttons. If I want to look at comics and cartoons, I'll pick up a comic book or stream something. Please, Google, take the cartoons away or, at least make them optional. Frankly, your Android app that you had in Aug/Sept 2023 worked flawlessly for me. Each upgrade has increased the number of clicks as well as becoming cumbersome This current one even looks bloated. Is there a link where I can get the old one back? 

Community Member

Why is there no GUI for the Nest Router or Nest/Google points?