Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Google router slow

Community Member


I'm also experiencing slow internet speeds. I only noticed it now that I have starlink - before my Internet was even slower. 

Directly connected to starlink I get up to 260 MBit/s, but behind the google router that drops down to 60 mbit/s.

For a while, doing a speed test in google home solved the problem, but now it stays slow no matter what I try. 

I'm referring to ethernet btw, 1 GBit/s connection, not via WIFI (not, that that would work any better). 



Community Specialist
Community Specialist

Hello sirdir, 

Thanks for reaching out to the Community forum. 

Please make sure that the Ethernet cable that you're using is undamaged and securely plugged in to both your Starlink modem and Google Wifi device. Check that there's minimal to no interference (concrete, bulletproof glass, metal, mirror, etc.) that may cause slow network performance. Visit this article about troubleshooting slow internet if the issue persists.

Keep me posted.


Community Member

I have to say, I’m quite disappointed by this product. 

First of all I think it’s really bad that you need to use the main device as a router for meshing to work. Others can do better. The whole configuration that is App only is less than stellar. Now way to save configurations etc. Anyways, I’ve got used to that.

Not I got faster internet (Starlink, about 260 MBit/s) and notcied that the Nest router is slowing down access quite a bit (not always, haven’t found out what it takes to get it back to being fast again). Instead of 260 MBit/s most of the time I only get 60. Via Ethernet cable, not via WIFI. sometimes I get the full 260, no idea when. Rebooting doesn’t seem to help, sometimes a configuration change will trigger it, or, when I first experienced it, a Speedtest from the app. 

Needless to say, when I connect another router, I always have the full 260 MBit/s.

Because of these issues I completely reset the access points and started from Zero. WHAT an experience. I almost had a heart attack. Yesterday I wasn’t able to get back online the whole day. At the end of the configuration of the AP the App says ‘Request failed. Please try again later’ or ‘The operation timed out and couldn’t be completed’. After switching to another WIFI and trying again hours later it suddenly worked. But when my stepdaughter complained about bad reception in her room I tried to re-add the nest point that had been close to her room before. Again, same problem. Tried for hours. Gave up. Tried again this morning. Same. With different phones/tablets. Android, iOS… no change. Found a thread that said creating a new room helped in heir case. Well, not in mine. 

In the end I switched off VPNs on my phone (although the other phone I tried didn’t have VPN) and switched off IPv6 on the router.. .and then it suddenly worked. No idea whether this has been it or whether it’s been coincidence. But the experience with this product is really the worst I have ever had with any AP/Router. If I still had my old Apple AC points I’d have switched back to those. 

Hey @sirdir .

Sorry you have had issues with getting Startlink working as expected with the Google Wifi. What you noted that resolved the issue is due to IPv6 not being configured on your Starlink. Starlink is IPv6 compatible but is not turned on by default in some instances or the gear they provided doesn't support it (IPv6 was just made available this year on Starlink). 

Try going into the Starlink device settings and make sure IPv6 is enabled. If you do not find the setting, then contact Starlink for an updated device if available for your plan. If it is enabled, then it is likely a compatibility issue with the Google Wifi and Starlink. 

Nah, that’s not what I said. What I said is I turned off IPv6 on the google router and suddenly I was able to install. Not sure whether it’s coinsidence or not. Now I’ve re-enabled it and it works fiine. We’ll see for how long.