cancel
Showing results for 
Search instead for 
Did you mean: 

My Wifi point device (model AC-1304) does not start (no lights on power on)

ablobo
Community Member

My Wifi point device (model AC-1304) does not start (no lights on power on). Even after I have disconnected from main power, wait 20 seconds, and re-plugged again. No response. No lights. Any suggestion how to solve?

13 REPLIES 13

olavrb
Platinum Product Expert
Platinum Product Expert

Might be a dead power adapter, are you able to try with a different one?


I don't work for Google.

ablobo
Community Member

No. I've tested with other power adapter.

Jeff
Community Specialist
Community Specialist

Hey ablobo,

 

Is this a brand new device that you're trying to set up for the first time, or is this something you have set up before and it suddenly stopped powering up?

 

Thanks,

Jeff

ablobo
Community Member

Hello Jeff,

This was my third Wi-Fi point, which just stopped working for no reason. The other two Wi-Fi points are working well.

Jeff
Community Specialist
Community Specialist

Hey ablobo,

 

With it being a point you already had, I would contact support either through phone or chat to see if you can get them to look more closely at your device. They'll have some tools to diagnose things directly. You can reach them here: https://goo.gle/31i1U5t. Just make sure to choose phone or chat as your method of contact and they can help you find a cause and solution. If you have any troubles reaching support, let me know.

 

Thanks,

Jeff

ablobo
Community Member

Hello Jeff,

 

I've tried the link  https://goo.gle/31i1U5t but until nothing of relevant info received. I've just turned off this WiFi point, and thinking to acquire a different vendor mesh router/wifi network. 😞

Jeff
Community Specialist
Community Specialist

Hey ablobo,

 

Go ahead and try filling this form out instead. This will prompt our internal support teams to contact you directly and they can help you out. Once you have filled the form out, let me know here.

 

Thanks,

Jeff

ablobo
Community Member

Hello Jeff,

The reply person from Google support about my problem was: "The Google Wifi point(setupXXXXX) that's no longer powering on, I regret saying that we've already covered all necessary steps to at least turn it to pulsing blue.".

Thus, I've basically a dead Goggle Wifi device. 😞

I will try to fill the form you suggest. Thank you again for your prompt help.

Regards,

Antonio

Jeff
Community Specialist
Community Specialist

Thanks, ablobo.

 

Support will stay in touch with you and help you work this out from this point. I'll check in after a few days to see where things stand.

 

Thanks,
Jeff

AbigailF
Community Specialist
Community Specialist

Hi ablobo,

Our support team has sent you an email. Kindly check so they can further assist you with your issue. Let us know if you have any other concerns or clarifications for now.

Best,
Abi

Jhonleanmel
Community Specialist
Community Specialist

Hi everyone,

Just one quick final check in here since activity has slowed down. We haven't heard from you in a while so we'll be locking this thread if there is no update after 24 hours. If you have any new questions, updates or just a discussion topic, feel free to start a new thread in the Community.

Thanks,
Mel

Hello,

I've just decided to give up from this Google Wifi point/router, and keep working with the other two until I will decide to acquire a new mesh network (probably from other vendor). Thank you all for your attention on my problem.

Regards,

Antonio

Jhonleanmel
Community Specialist
Community Specialist

Hi ablobo,

 

We're sad to see you go. We hope we can make it up to you in the future. Send us a message if you change your mind. Please let us know if you have any other questions or concerns as I will be locking this thread after 24 hours.

 

Thanks,
Mel