Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Wifi Double NAT

Community Member

I have a Nest Wifi Mesh system with three pucks (one connected to the ISP and two pucks at either end of the house).  I am constantly having a Double Nat issue where whenever anything tries to upload, it shuts down the entire link for everything except the upload.  I have been informed by tech support that it is Double Nat and to have my ISP come and set their router to bridge mode.  A few months ago, the ISP came out and spent 2 1/2 hours at my house trying to help me get everything worked out, but to no avail.  

They had no issue setting their router to bridge mode, but once the router was in bridge mode, we could not get the Nest router to connect with the ISP's login info.  We tried everything and finally had to give up, and just set it up like it was and deal with the issue.  I can't deal with the issue anymore. 

How do I get the Nest system to actually connect with my ISP once the router is is bridge mode?


Gold Product Expert
Gold Product Expert

Hey @brothertroy777 .

Just a few questions:

  • Who is your ISP?
  • What is the make/model of the modem?
  • Do you get connectivity to the internet if you connect directly to the modem?

Hey folks, 

@PatrickP_Viking, appreciate your helpful response. 
@brothertroy777, chiming in to ensure everything is good here. Were you able to see the questions above?


Sorry it has taken me a few days to get back on here.  


1) My ISP is a local company (Lipan Telephone Company) that put the phone lines in our area originally.  They are slowly upgrading to fiber, but right now it is vdsl I believe. 

2) Modem/Router is a comtrend VR-3033

3) I'm not sure how to answer this question.  If the modem is put into bridge mode, I can't receive internet through it without somehow entering the username and password.  That's where we get stuck. The Nest can be connected, but when we switch the comtrend to bridge mode and change the Nest to login with the Pppoe settings, it never connects although the comtrend shows to be connected to the dsl according to the tech. 


I am really at a loss. 

Thanks for the additional information @brothertroy777 .

These articles should help you get the PPPoE connection setup:

WAN settings 

PPPoE issues during Google Nest Wifi or Google Wifi setup 

Hello everyone, 

Thanks again for lending a hand, @PatrickP_Viking.
@brothertroy777, I wanted to follow up and see if you are still in need of any help. Please let me know if you are still having any concerns or questions from here, as I would be happy to take a closer look and assist you further.


Community Specialist
Community Specialist

Hey brothertroy777,

Checking back in should you still have some questions here. Let us know by replying to this thread. 


Community Specialist
Community Specialist

Hi brothertroy777,

We haven't heard from you in a while so we'll be locking this thread if there is no update within 24 hours. If you have any new issues, updates or just a discussion topic, feel free to start a new thread in the Community.