Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Speed capped after Home app speed test until factory reset.

Community Member

Has anyone experienced an issue where doing a speed test using the home app will cap the speed of the internet permanently until a factory reset is performed? 

I'm on a 1000down/50up Mbps plan, and I was experiencing slow internet speeds, approx 50Mbps down, so I factory reset my nest network. Once the nest router is ready to set up again, with a device connected directly to the nest router, I run a speed test at,, google speed test, and get several hundreds Mbps down. Then I set up the router and my 1 nest point, do a speed test on any of my devices with one of those three websites, both wired and wireless, still several hundreds Mbps down. I do a speed test through the Home app, and I get approx 50Mbps down, then do a speed test with one of those sites and now I get the same approx 50Mbps down.

I factory reset, start again, before setup, good speeds through those sites, do a speed test through the Home app, approx 50Mbps down, do a speed test on those sites again, now they show approx 50Mbps down.

I'm confident that doing the speed test through the Home app is part of, if not the cause of the issue. There is no time period between the factory reset and the speed tests sites where the speed will drop. After setting up my nest router+point after a factory reset, I can do a speed test immediately after a set up, wait 24 hours, and get several hundreds Mbps down. The moment I do a speed test through the Home app, my speed gets capped at around  50Mbps down and I have to factory reset again. 

I'm not changing any settings, I'm literally going from factory reset > vanilla network setup > speed test. 

As long as I don't do a speed test through the Home app, my speed won't be capped, so that appears to be a safe work around right now, but does anyone have an idea as to what is happening?


Community Member

Mine is doing something similar. However, my speeds have sucked from the get go. I am getting earth shatteringly slow speeds, like 20-50 mbps with a 1/1 gig connection. Use my ASUS and I get 950mbps up and down. I thought these routers were supposed to be good or I wouldn’t have wasted the money. Seems like mine slows down as soon as I add a mesh point.

Community Specialist
Community Specialist

Hi folks,


Thanks for reaching out. I'm sorry to hear that you're experiencing an issue with the speeds. I'd love to know more about this and I have a few questions:


  • What's the speed test result when you do it from the Google Home app?
  • What's the firmware version of your Google Wifi?

Looking forward to your response.




Community Member
Hi Edward, 
As I said multiple times in my original post, the test results using the Home app are always approximately 50Mbps down, and the moment I use the home app for a speed test, my entire network's download speed is throttled at the same ~50Mbps until I factory reset the nest router. I just confirmed this again now, as I hadn't used the home app to run a speed test since my original post, after which I had to factory reset my nest router, so I was consistently getting 300+Mbps down.
I ran a speed test on my phone using the Speedtest app, got 361Mbps down. Switched to the home app, ran a speed test, got 49Mbps down. Switched back to the app and ran another speed test and got 46.6Mbps down. I now have to factory reset my router again. I recorded the screen on my phone, and you can view the video on dropbox here
Software version is 14150.43.81

Community Member

bumping this topic. Experiencing the same.  Nest router is throttling connection during speed test.  My data:

ISP: Spectrum

Plan: 400/20

speed test at modem: 400/20

speed test in Google Home app: 400/20

speed test from any LAN client (wired or wi-fi): 250/10