cancel
Showing results for 
Search instead for 
Did you mean: 

Why can't I get the Nest Wifi Pro latest firmware?

Aria
Community Member

I've tried everything including factory resetting the Nest Wifi Pro and it will not update to the latest firmware.  I'm stuck on 1.63.318999 which means with my PPPoE connection I'm limited to around 30-50Mbps when I know I'm getting 900Mbps from BT.  I've tried;

- Restarting network via app

- Restarting each point by unplugging and plugging it back in

- Factory resetting and setting up again from scratch

- Leaving it alone to see if it'll do it itself overnight

*myrouterip*/api/v1/status  still shows;

      "blockingUpdate": 1,
      "softwareVersion": "1.63.318999",
1 Recommended Answer

Aria
Community Member

Finally updated and seems to have resolved the issues for me

View Recommended Answer in original post

14 REPLIES 14

RXShorty
Gold Product Expert
Gold Product Expert

Hi @Aria 

The firmware upgrade roll out is taking some time to reach all the devices.
It should arrive this week if all things are going according to plan. 😉

So please give it some more days to arrive, sorry you have to wait while having issues. 🙄

Is there a new update or is it that you wish there is, and ready, and eventually to be pushed?
According to Google online support, there was no information on ETA.

Can you please provide the new firmware version?

Also it would be great if you can provide a link to the changelog?

Thanks

Hi @ideolog-twenty- @Aria @ziggy86 

As I am not a Google employee but a volunteer I don't have all the insights but have some information about the newer firmware version: 1.63.324946 (this is the one that runs on my own Google Nest Wifi Pro)

Currently, I have no changelog on what has changed exactly but it has to do with performance issues.  🙂

have you seen improved performance from the newer firmware?  I am nearing my return window and at this state, I cannot justify keeping the Nest wifi pro.  

Hi @WindTreeSong 

I don't have any performance issues. My ISP provider does not use PPoE. So I am afraid I am not really a usefull resource right now. 🙂

I am currently on 1.63.318999, which was the 2nd software update I received yesterday (just before that I was on 1.63.324969).  Is there a newer version out there? If so, does it seem to improve anything?  

Sounds like you've gone backwards.  1.63.318999 is older than 1.63.324969 just based on the firmware numbering.

Seems like you are back to an older version, strange. I am still waiting for the update.

MarinaN
Community Member

Hi @RXShorty !

my current version is 1.63.324946 but I’m still experiencing connection issues.

do you know if there is a new version coming up?

RXShorty
Gold Product Expert
Gold Product Expert

Hi @MarinaN

I am only aware of the version you are running now.

So I don't have any news on a new firmware update, I am sorry. 🙄

Did you try restarting your network already within the app?

ziggy86
Community Member

This is very frustrating. I too am waiting for this to see if it fixes my issues. leaning towards returning and getting something else.

Dork1337
Community Member

wish there was a force update button 

Aria
Community Member

Finally updated and seems to have resolved the issues for me

Jhonleanmel
Community Specialist
Community Specialist

Hey there,

Awesome — glad to hear that your issue is fixed. It looks like we can consider this one complete, so I will lock the thread shortly unless I can help out with anything else.

Best,
Mel