Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

iPhone X user w Nest Wifi router, cannot establish a wifi connection after ISP equipment update

Community Member

After an update to my internet service provider's rooftop equipment (Monkeybrains), I can't establish Wifi on my Google Nest Wifi router.  The setup process fails repeatedly. (I had no choice but to re-do the "Set up a New Device" process w my router bc the ISP equipment update --> new IP address.)

I talked to Google Nest Wifi support x2 hours yesterday, but no fix. They think this is a Google Nest Wifi/iOS bug which will take take to find and resolve. Hoping someone here has had a similar experience and resolved it.


Google Nest Wifi router/mesh system (new 9/2021), Google Home app, iPhone Xs, iOS 15.1

Wired connection working fine @1 gig download/upload speeds 

Same router + iPhone + Google Home app worked for the previous 4 months.

Nest Wifi support and I tried:

- factory reset the router several times

- deleted and reinstalled the Google Home app

- deleted and reinstalled my "home" and all my devices within the reinstalled Google Home app

- ran the connection status API, and the wan shows that it should be working:

captiveportal false, ethernetlink true, gatewayIP address (withheld), invalid credentials false, ipAddress true, ipMethod dhcp, ipPrefix length 25, lease durations seconds 5578, local IP address (withheld), name servers (withheld), true, pppOE detected false, vlanScanAttemptCount 1, vlanScanComplete true



Thank you in advance for your suggestions/ideas/stories of similar experiences.


Community Specialist
Community Specialist

Hey, MinSF.
Sorry for the late response here, but I wanted to check in to see if you were still having this issue and to see if you have done any additional troubleshooting so far. If you still need help, let me know and I'll be happy to work on this with you.

Community Member

Thank you - after much delay, my wifi service had to re-send codes to my router. After that, the Nest router activation was quick and easy. MF 

Community Specialist
Community Specialist

That's great news, MinSF. Thanks for following up and letting me know you got it sorted out.

I'll go ahead and mark this as resolved. If you need anything else at all, go ahead and open up a new thread.