cancel
Showing results for 
Search instead for 
Did you mean: 

Advertisements playing, despite being Youtube Premium user.

Uriah
Community Member

Hello, for the past few weeks, Advertisements have begun playing on my Google Home Max, despite being a Youtube Premium user. I'll ask Google to play music on the device or group of living room devices, then after one song it will start playing an Advertisement...

I've confirmed my Google Home app is still set to use YouTube Music service to play from.
I've confirmed my subscription is very much still active, I've been sub'd for years to Google Music which gave me YT Red, which now turned into the YT Premium which Youtube Music uses.

yt
Can you tell me why I'm getting ads on Youtube Music through my nest device now? It's this how the paid service works or is something misconfigured?

194 REPLIES 194

Conall
Community Member

Same issue here. Very annoying. Basic troubleshooting of resetting, redos loading app, signing out in does not work

Rainman43CZ
Community Member

I have same issue. Hard reset does not help at all. Any idea how to solve it?

Jimbabwe
Community Member

Same issue.  Frustrating!

GarrettDS
Community Specialist
Community Specialist

Hey there, 

Sorry to hear about the issues with Youtube, I'm sure it's frustrating. 

I would suggest searching through the Youtube Help Center or contacting their support directly as this is not something that we support in this forum. 

 

Best regards, 

Garrett DS

Conall
Community Member

Hi there, contacted both google home support. They went through troubleshooting with me and it seemed clear the fault was with google nest. All other YouTube services on phones iPads and ccwgtv work fine. Even though this was the case they said the same thing “contact YouTube”. YouTube thought this was very strange when I actually called them. They humoured the other support team and checked all subscriptions were active. Then confirmed it is definitely not a YouTube issue and a nest issue. This is an issue for this forum.

 

This issue is growing and getting worse. All of speakers are now playing ads, despite having a premium membership. This needs to be fixed, my kids are demanding Alexa for Xmas because of this

which is where i started, as i figured they were the problem but they sent me here

Notanotheracct
Community Member

I am at the end of my rope. My Google Home Mini is connected to my YouTube premium subscription (which includes YouTube Music), but refuses to recognize that fact and is constantly playing ads. I like to have it play music for my dog while I'm away so I can't just cast my YouTube to the Mini. But the ads are ridiculously loud and make my dog anxious when the calming sounds are interrupted by a bombastic commercial. It says my subscription is active, and yet won't actually let me have any access to my playlists or to any of my other member benefits. Please help. 

Screenshot_20211031-075730.png

same problem here, but I have a group of Google Home Speaker so all runing ads, google knows that they did something

GarrettDS
Community Specialist
Community Specialist

Hey there, 

Thanks for letting me know what you have tried. 

To get a better understanding of where the issue might be, would you mind doing a factory reset on your device and let me know if that works? You can also try unlinking and relinking your device as well. 


I look forward to hearing from you. 

Best regards, 

Garrett DS

Conall
Community Member

Hi Garrett

I have factory reset many of the devices many times. Also unlinked and rekindled accounts. Signed out and in. Deleted and reinstalled app. The problem keeps occurring. But not every time. When I called google home support they could not solve the problem and escalated  it to one of their “experts”. Haven’t heard back on a couple of days. 

It seems to be a common problem on forums so hopefully someone is working on it.

my expert at youtube music said its the google home that is the problem, not them. grrrr

Freja
Community Member

I did this as well and then it worked fine for a week. Now I am back at hearing ads despite having youtube premium and it's both frustrating and infuriating to feel powerless. It seems to me that it's a google home issue seeing how many others experience the same thing, and I hope you can fix the issue. The sooner the better.

GarrettDS
Community Specialist
Community Specialist

Hi there, 

Thank you for letting me know what troubleshooting steps you've taken, and I apologize that you're still experiencing this as I'm sure it's frustrating. If you happen to have a Case ID I can pass it forward and get it escalated to have someone take a look at it. 

I look forward to hearing from you. 

Best regards, 
Garrett DS

JohnyRicio
Community Member

I have same issue. And it is worst and worst. Few days before was one advertisment after 5 song. now is adwertisment, sond, adwertisment, song... It is really crazy...  😞

GarrettDS
Community Specialist
Community Specialist

Hey there,
Just wanted to jump in here to check to make sure that you saw our response. Please let us know if you have any other questions or concerns as I will be locking this in 24 hours.

Have a great day.
Garrett DS
 

I am experiencing the same issue with my Google home and YouTube premium.  Plays 1 song then commercial, repeat process. This has been going on for about a month. I have Uninstalled both apps on my phone, reset Google home, reinstalled apps and issue continues. I contacted YouTube and they humored me but said it's not on their end. 

With all of the complaints regarding this, and the amount of time this has been going on, is there not a solution to this issue yet?

mwmzmwm1
Community Member

I have the exact same problem and it started like a week ago. It makes my Google Nest speakers and my YouTube Premium account WORTHLESS and a complete waste of my money.

Freja
Community Member

Yeah this has been going on for a bit more than a month for me, and I really feel like the subscription that I am paying I get nothing for at all.

engineerboy
Community Member

Do not lock this topic, it is active and apparently growing, as I now have it. We've had Google speakers and Youtube premium for years without issues, then starting in the last few days we are getting ads when we play music.

This needs to be fixed/addressed as it is extraordinarily disconcerting. Our household is basically ad free for streaming video and music so having ads is a terrible precedent for our kids, one which we have happily paid to avoid, until now.

Agreed 

GarrettDS
Community Specialist
Community Specialist

Hi there, 

Sorry to hear that you're still experiencing issues on this. I would suggest reviewing this article to see if that will help with any troubleshooting steps. Please double check that you are signed into the correct account when viewing videos as well. 

 

Please let me know if you have any other questions. 

Best regards, 

Garrett DS

Link not working... error 404... and it is not about video... but about youtube music for premium. 

This link is defective with a 404 error.

????

We don't want articles...We want it fixed or we'll all cancel our Premium account.

GarrettDS
Community Specialist
Community Specialist

Hey everyone, 

I've been in contact with the appropriate team about this issue and I just have a few more probing questions to ask. 

  • What kind of ads are you getting?
  • Is it only when you play music or is it videos as well?

I'm looking forward to hearing from you. 


Best regards, 

Garrett DS

It's "you should update to YouTube Premium to stop hearing ads" ads.

Didn't try videos... I only play music on my speaker groups

Not sure about video, exclusive audio. I receive premium account upgrade ads ...signed in with premium

It's not just ads...It says specif songs are only available on youtube premium. Well the app say I have Premium and so does my bank account.

 

It was just ads for shops here in Germany and the occasional ad for the benefits of having YouTube Premium. Mine have seemed to stop for about 2 weeks now. I don't know why.

I have:
YouTube Premium Family with 5 members
Same account (Mine) in my Google Home
Nest Wifi router with one Nest Wifi point
Nest Hub (Smaller one)
3 Nest Minis (3rd Gen)
1 Nest Mini (2nd Gen)

I'm not sure if this helps, but I couldn't play from my phone to any of my speakers when this was happening. It would connect, make the sound on the speaker, then stop playing on my phone and I couldn't start it again OR it would disconnect and continue on my phone.  My phone never played ads that I recall. I reset everything in the whole house, including all my other smart device brands and router and haven't had the issue again yet.

ontario lottery was the last ad i saw

GarrettDS
Community Specialist
Community Specialist

Hey there,
Just wanted to hop in here to see if we still needed help on this. If you found a solution that worked for you on this thread, please mark that as an accepted solution so that it will help others that may come onto this forum to fix their issue. 

 

If there are no other issues or questions I will close this within 24 hours. 

Have a great day.
Garrett DS
 

Conall
Community Member

Hi Garrett

Yes the issue is still ongoing and seems to be becoming more common on this forum.

Please do not close this thread until a solution is found. 

I also have not heard back from google in regard to my support case for some time. They seem to be struggling with this one.

Please do not close this thread. I am also experiencing ads in between every song on my google home speakers despite being a current YTP subscriber. My issue is exactly as described in this forum, none of the standard correctins have worked. My account works great on all other devices except music on my google home. My wife can play music ad free (voice match is set up for both of us) but anytime I try it plays ads for YTP. Extremely frustrating and disappointing. Issue is NOT resolved, Garrett

The solution will happen when Google fixes it.  All we are doing is search for half-ass work-arounds and try to minimize the pain and hassle we're suffering through.

Please do not close this and give the impression to people who find it that it is "solved".  It absolutely is not solved.

This is not resolved and I haven't seen a solution from Google except for read help files which all of us have done for hours.

Still getting adds, so please don't close this until everyone has the issued fixed.

 

GarrettDS
Community Specialist
Community Specialist

Hey there, 

Thanks for letting me know that some of you are still having this issue. I just wanted to confirm that you have all double checked that you're using the same Google account for both the YouTube Premium membership and Home app?

 

I look forward to hearing from you. 

Best regards, 

Garrett DS

To re-iterate, this is not a "user error" issue or a misconfiguration.  This is something broken with Google (either Nest/Google Assistant or with YouTube Music).  To repeat my comment from a few days ago:

---------------------------------------------

Same issue here.  I get an ad in between every single song when I play music from YouTube Music to a Smart Speaker group.

 
Confirmed:
  • I have an active YouTube Music Premium subscription
  • My YouTube Music Premium subscription is linked to the same Google account as my smart speakers
  • YouTube Music is set as my default Music Playback Service in Google Home App settings
  • This just happened starting within the last few weeks
  • I have not made any changes to my Google Home App settings, or to my Smart Speakers, or to my Google or YouTube Music account
  • This seems to happen when I specifically ask for music to be played on a speaker group, "Hey Google, play music on Office Group"
  • The issue doesn't seem to happen when I ask a specific/individual speaker to play
  • This doesn't seem to be affecting every Speaker group; I have half a dozen, and the one that consistently plays adds now is the one with my Google Home Max speakers.
    • My other speaker groups all consist of older Google Home Mini speakers, Google Home speakers, a Chomecast Audio speaker, a Nest Hub, and non-Google Smart Speakers that support Google Assistant
  • This is not an App/Phone issue; there is no phone or app in use or involved when I'm requesting music from Smart Speakers via voice
  • This is an issue between YouTube Music and the Google/Nest Home Smart Speakers
    • Unlinking and relinking speakers doesn't resolve the issue
    • Rebooting speakers doesn't resolve the issue
    • Uninstall or reinstalling apps doesn't resolve the issue
    • Factory resetting Smart Speakers doesn't resolve the issue
  • This is a problem on Google's side that Google needs to fix; this is not a user-fixable issue
  • This is being reported by a number of people across various support and community forums
  • This is incredibly annoying