cancel
Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Fuchsia v12 Speaker Group Issue when Chromecast Audio is present?.?

Gary_M
Community Member

My Nest Hub (Gen1) which is in the preview program recently got the Fuchsia 12 update and I noticed that it stopped playing audio from a speaker group it is a member of.  The speaker group contains the Nest Hub in question plus 4 Nest Minis, 2 of which are in a stereo pair, and one Chromecast Audio device. Prior to the Fuchsia 12 update if I asked Google Assistant to play NPR on the speaker group for example, NPR would start playing on all the speakers in the group as expected. After the update to Fuchsia 12 the same Google Assistant command would start playing NPR on all speakers in the group except for the Nest Hub. I've confirmed the Nest Hub was still in the group, I removed it and re-added it to the group, I rebooted all the speakers in the group, even deleted the speaker group and recreated it and I get the same results. 

Doing some more debugging I created a new speaker group with just the Nest Hub in it and asked Google Assistant to play NPR to the new group and it worked. I then started adding the other speakers from the original speaker group to the new one one at a time and  asking Google Assistant to play NPR after each add and things were looking good until I added the Chromecast Audio device to the group. When it's in the group the Net Hub will not play audio from the speaker group. I removed the Chromecast Audio and started playing something to the group and the Nest Hub started working. I added and removed the Chromecast Audio to the group a few times just to make sure and every time it's in the speaker group the Nest Hub will not play audio from the speaker group. One time I had audio playing to the group and the Nest Hub was working, I then added the Chromecast Audio to to group and audio started playing out of it and the Nest Hub kept working BUT if I stopped audio to the speaker group and then told Google Assistant to play something to the group, the Nest Hub would not play audio again.

I'm not sure if this is the best place to report this issue but figured it was a good starting point and also to see if anyone else was having a similar issue. 

5 REPLIES 5

Juni
Community Specialist
Community Specialist

Hi Gary_M,
 

Thanks for reaching out and for the information you’ve shared. Try to create a new home structure and move your devices there then create the speaker group. Observe if it makes a difference. Also, please provide us with the Chromecast Audio firmware version by following the steps below:

 

  1. Make sure your mobile device or tablet is linked to the same account as your speaker or display.
  2. Open the Google Home app Google Home app.
  3. Touch and hold your device's tile.
  4. At the top right, tap Settings and then Device information.
  5. Under "Technical information," find Cast firmware: X.XXX.XXXXX.

I look forward to your response.
 

Regards,

Juni

Gary_M
Community Member

Sorry for the delay.

Device Information:

(#1) Nest Hub (gen1)
- System Firmware: 12.20230611.1.58
- Cast Firmware: 1.70.371084

(#2) Chromecast Audio:
- Cast Firmware: 1.56.281627

(#3) Nest Mini:
- Cast Firmware: 2.57.375114

All devices are on the same network subnet as is the Android phone (Pixel 6P) I'm using to make changes via the Home App as well as issuing Google Assistant commands. Also all devices are part of the Preview Firmware Program.

I create a new home called "Test" (very creative I know) as requested and moved the 3 device listed above into this new home. I also deleted my existing speaker groups from my primary home.  I then switch into the "Test" home and made sure the 3 devices listed above were in there. I then created a new speaker group call "Bridge" (Star Trek anyone). I then tested several combinations of speakers in the group and noted the results below. I used the following command via Google Assistant on my phone to play audio to the speaker group: "Play WUNC on Bridge" and "Stop Bridge" to stop audio to the speaker group.

Device Combo in Speaker Group --> Results

  • #1 --> Worked as expected
  • #2 --> Worked as expected
  • #3 --> Worked expected
  • #1, #2 --> Audio plays on #2 but not on #1
  • #1, #3 --> Worked as expected
  • #2, #3 --> Worked as expected
  • #1, #2, #3 --> Audio play on #2 and #3 but not on #1

Some interesting observations:

  • There were a few random times where I put #1 and #2 into the speaker group and the first time I asked Google Assistant to play audio it actually did work but if I stopped audio and then tried to play audio again to the group, #1 would not play audio. I tried a few more stop and starts but #1 would not start playing again.
  • Like above there was a random time when I had #1 and #3 in the speaker group and #1 would not play audio. Doing a stop and start didn't seem to get #1 working. I eventually removed #1 from the speaker group, played audio to the group where #3 was the only speaker in there which worked, stopped audio, added #1 back to the group and then started audio again and that seem to get #1 and #3 playing nicely with each other again.
  • When audio does work to #1 you will see cast icon pop up on the screen and then switch to the player showing what was playing. The times it would not play audio, the screen doesn't change. As in no cast icon or what's playing. It just stays on whatever was already on the screen like the clock for example. 
  • In the case where #1 was in the speaker group but didn't start playing I could see via the Home app on my phone that audio was playing to the speaker group. If I click on the Cast icon on this notification it will pull up a list of devices with check marks next to the devices currently playing audio. The #1 device was listed but did not have a checkmark next to it. If I click on the #1 device to add it to the cast, audio would start playing out of device #1 BUT the notification in the Home app which said the name of the speaker group "Bridge" before now says "#2 + 2". Basically listing each device separately instead of them being in speaker group "Bridge".
  • In all the combo testing I never had #2 or #3 not play audio when they were in the speaker group.

As I noted in my original post, I've had the original speaker group setup for a few years with the #1 devices in it pretty much since I bought it and never had this type of issue. The only change that seemed to correlate with it breaking was it getting the v12 Fuchsia upgrade recently.

Princesss
Community Specialist
Community Specialist

Hello there,

 

We appreciate all your efforts. We'd be happy to take a look into this for you. Please fill out our Contact Us Form with all the needed information then let me know once done.

 

Best,

Princess

Gary_M
Community Member

Form submitted. 

Princesss
Community Specialist
Community Specialist

Hey Gary_M,

 

Thanks — we got your form and we've escalated it over to our higher level of support for further review. Please keep an eye on your inbox as someone will get back in touch with you soon. 

 

Best,

Princess