Showing results for 
Search instead for 
Did you mean: 

Google Near Hub stuck on Grey Screen

Community Member

My Google nest hub is stuck on the grey screen despite soft reset and factory reset. Nothing is helping. Please help. 



Gold Product Expert
Gold Product Expert

Are you using the official power adapter and cable that came with your device? Have you tried plugging the device into a different power outlet and rebooting it? You can also try recovery mode followed by a factory reset by following the steps below.

  1. Place the device in Recovery Mode (unplug the device then hold down the volume button while plugging device back in. Release the volume button once the device turns back on.)
  2. Attempt a factory reset once the device boots into Recovery Mode (hold down both volume up and volume down buttons at the same time.)

Yes. I have tried all of this. Very disappointed and in reading a lot of other comments on the same issue, I cannot understand why it’s not being addressed. 

Appreciate you confirming that, I know this will be frustrating. In that case, I'd recommend that you contact the Google Nest support team directly. They'll be able to check on further possible troubleshooting options and can advise you on next steps.

No. I still have no solution and a useless Google Nest Hub. 

I appreciate that but we've exhausted the troubleshooting steps we can attempt here in the community. If you prefer, I can ask a community specialist to chime in here to check on other possible troubleshooting options with you?

Community Specialist
Community Specialist

Hey folks,
It looks like we haven't heard back from the OP so I'm going to go ahead and lock the thread. If you have any further questions or concerns, feel free to create a new thread.

Have a great day,
Garrett DS