cancel
Showing results for 
Search instead for 
Did you mean: 

Google hub problems

Rangarajan70
Community Member
  • Hub problem    The hub is stuck in G loop for the last 6 months with no way to repair it or approach Google support.  I have chkd Forum tried all things possible but seriously nothing happens.  Google should address this issue seriously I think there would be many more such people like me
10 REPLIES 10

Start with the basics: Reboot and check for updates. If everything looks all right, head to the Home app and look at the Nest Hub settings to make sure the Home Monitoring option is turned on. If all else fails, remove the Hub from your Home app and do a full factory reset on it.

 

Regards,

Rachel Gomez

My device is not being detected by my device as it is stuck at G logo 

Princesss
Community Specialist
Community Specialist

Hi Rangarajan70

 

I know how challenging it can be not having a working device when needed. Let's go ahead and try these steps first:

 

  • Have you tried plugging the device to a different power outlet?
  • When was this issue (stuck on gray G logo) first noticed?
  • Was the device already in this state when you first discovered it?
  • If no, were you in the middle of interacting with the device when it happened? If so, what were you trying to do?
  • Did you unplug the device or was there a power outage shortly before you discovered this issue?


Please try these steps below that may help us fix the issue:

 

  • Place the device in Recovery Mode (unplug the device then hold down (long press) the volume up and volume down buttons while you plug the device back in. 
  • Release the volume button once the device turns back on.)
  • Attempt a factory reset once the device boots into Recovery Mode (hold down (long press) both volume up and volume down buttons at the same time.)


Let us know if that works.

 

Best,

Princess

Hi Princess,

There was brief power outage after which the device wasbstuck to on G logo and i have tried all things to no avail

 

Regards 

R Rajan

Juni
Community Specialist
Community Specialist

Hi Rangarajan70,

 

DId you try the steps provided by Princess? Are you still using the original power cord? 

 

Keep me posted?

 

Thanks,

Juni

Juni
Community Specialist
Community Specialist

Hi there,

 

Buzzing in — do you still need our help? Don't hesitate to reach back if you do.
 

Regards,

Juni

Azarco
Community Specialist
Community Specialist

Hello there,

 

One quick final check in here since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need assistance, feel free to start a new thread in the Community and we’ll be happy to help.


Best,

Alex

Dan_A
Community Specialist
Community Specialist

Hey folks,

 

@RachelGomez123, thanks for the help.

@Rangarajan70, that certainly hasn't been easy for you ―  When did this start to happen? Do you have the Google Nest Hub or the Google Nest Hub(2nd Gen)? Does it show the G logo on the screen? Follow these steps:

 

  1. Use the power adapter that came with the device.
  2. Plug in the device to a different power source.
  3. Attempt a factory data reset.

Keep me posted.

 

Best,

Dan

Dan_A
Community Specialist
Community Specialist

Hi Rangarajan70,

 

I wanted to follow up and see if you are still in need of any help. Please let me know if you are still having any concerns or questions from here, as I would be happy to take a closer look and assist you further.

 

Regards,

Dan

Jake
Community Specialist
Community Specialist

Hey there,

 

I wanted to check in, and let you know that I will be locking the thread in 24 hours.

 

Best regards,

Jake