Showing results for 
Search instead for 
Did you mean: 

Nest Hub Max voice assistant doesn't play any movies or videos on TV with "Chromecast + Google TV"

Community Member

I just bought a Google Nest Home Max, it is all working well except the fact that if I ask "Hey Google, play XXXXX on Netflix on my TV", in which TV is the name of my Chromecast with Google TV, and it doesn't work. 
The assistant understands what I want and repeats it, but nothing happens in the TV.
If I want to play music on my TV and I say "Hey Google, play XXXXX on Spotify on my TV" it works, but not video apps (Youtube, Disney+ and Netflix).
When the title in Netflix is not available, I get a screen with the image of the movie and saying it is not available.

If I use the Chromecast control voice assistant it works well.
The only thing that happens when I ask to play some video on my TV is that it turns the TV on and I get a message in the TV: "RC pass-through active". I use a Philips Ambilight TV, they use EasyLink as a technology for RC pass-through. 
If I turn EasyLink off and on it works for some time and then it doesn't work anymore. 


Platinum Product Expert
Platinum Product Expert

HI @danielbpc this might be a silly question, but have you linked your accounts for your streaming services in the Home app? Those accounts need to be linked, otherwise, the speaker device has no clue where it's supposed to find whatever it is you want to watch.

Hi @GothamNY 

Thanks for the answer but I have already linked the streaming service in the Home app. And it works well for sometime so it shows that it was configured correctly, and then it just stops working. 

Platinum Product Expert
Platinum Product Expert

OK, good to know, so now that that is out of the way. When you linked, did you recall being dumped to a screen requesting permissions to your external accounts? Let's try unlinking the accounts and relinking them in the Nest Home app. Let's see if that re-establishes the connection.

I must say I'm a bit confused how it worked for some time since you start your post with "I just bought..." Your setup with Chromecast isn't the same as the Nest hub device, so making the comparison is a false equivalent -- they are not the same device and don't necessarily have feature for feature parity with Google Assistant and voice.

Also, the Nest Home devices need a secure WiFi network connection. It seems you're using a non-standard setup -- but I do know both the Nest device and TV need to be on the same WiFi network and full access must be provided. If Easylink blocks this in any way that could be the problem. 

Community Member

Hi @GothamNY .
I just unlinked and linked again in my Google Home app. It didn't send me to a screen asking for permissions, only opened my account (e.g. Netflix) to put user and password and then to select profile that will be used for google assistant. After that it was linked in the app but didn't solve the problem. 
Sorry if I was confusing, what I meant with worked for some time is for some hours. I bought the Nest Hub Max for Christmas and I am using since then. So yesterday for example it was working for some hours during the day, so I could say "Hey Google, I want to watch The Office on Netflix" and then Google Assistant answered "Ok, playing the Office on Netflix on your TV" (my TV is the name and the default video player for my Chromecast + Google TV. After that it turned the TV on, showed message in the corner "RC pass-through active" and played The Office as expected, so I was super happy.
But in the evening it just stopped, so if I ask the same thing, Google Assistant will reply the exact same thing, I will get in my TV the same message in the corner "RC pass-through active" but nothing happens. 
This time I tried to put EasyLink off and On again but it didn't work anymore. 
If I ask the Google Assistant from the remote control from Chromecast+Google TV it works, but as you mentioned, it is a separate device. 
I am in a secure Wi-fi, all devices connected to the same Wi-fi and the connection is standard. I only mentioned this EasyLink because it is related to this "RC pass-through active", but I don't know if it has anything to do with it. 
Thank you again! This functionality is one of the most important for me, and the integration with Chromecast was the main reason that I chose Nest Hub Max instead of Alexa, so thank you for trying to help me to fix it. 

One additional comment: it also happens with Youtube, which I don't really need a linked service. 

Platinum Product Expert
Platinum Product Expert

Glad unlinking and relinking fixed it for you -- it's bound to happen again, but now you'll at least know some quick troubleshooting steps to bring things back online. Sounds like the token or whatever is used is expiring too quickly for some reason. What handheld device are you using?

If the unlinking suggested solved the issue, please mark it as a solution so as to help others and I can have a member of the team lock the thread.

No, sorry, unlinking and linking it again didn't work. I just said I tried that but no success. 

Additional comment: I removed completely the Chromecast +Google TV device from Google Home and reconfigured it all from scratch.
It solved the problem for 30 minutes and then it stopped working again.
I think I will give up and return the product 😞 

It is very disappointing because I see my friend with a Chromecast gen 2 and a Google Nest Hub (2nd generation) saying "Hey Google, play The Office on Netflix" and having success. 
While I am with Google Chromecast with Google TV and Google Nest Hub Max and can't do it. 

One update, it was solved for me if I say "Hey Google, turn on the TV" (even if it is already on), and then say "Hey Google, play The Office on Netflix on TV".
Then it works.
It is a small bug still because you need to ask to turn on the TV even if the TV is already on, but at least I could solve it and keep the Google Nest Hub Max.

Community Specialist
Community Specialist

Hey folks,
It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread.

Have a great day.
Garrett DS