Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest hub max will not connect to wifi

Community Member

Nest hub max.

Bought one yesterday.

Got it connected to my Google home first try fine. Set up the camera. Did all my personal settings. It was working fine. Made a duo call etc.

Goes to bed.

This morning it's dropped off and looks to want resetting up from scratch.

Tried restart it does same thing. So I deleted from my home and it won't reconnect as it says added to another account, I presume my own. So factory reset. I can connect to it but it won't join my WiFi network.

Tried rebooting all my devices, same.

Restart my WiFi and router. Same.

I've tried various combinations of factory reset and my home network reboots it will not connect.

Have no issues with the 3 smaller 2nd gen hubs, my doorbell or my phone/tablet.

Very expensive item for it to behave so poorly within 12 hours of setting it up.


Community Specialist
Community Specialist

Hi 5tiffler,

We're sorry for the trouble this may have caused you — let's see what's going on.

Do you have a dual-band router? Make sure your Google Nest Hub Max is within 15-20 feet of your router. Try reinstalling your Google Home app.

Let us know how it goes.



Community Specialist
Community Specialist

Hey 5tiffler,

How's it going with your Nest Hub Max? Let us know by updating this thread and the Community will be happy to lend a hand.



Community Specialist
Community Specialist

Hello there,

I want to ensure you are good to go, and everything is working properly. Please let me know if you are still having trouble, as I will be locking the thread in 24 hours due to inactivity.