Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

How to remove an unavailable device from a Routine

Community Member

I had Christmas lights set up using a FEIT electric 🔌. I have wrapped it up and so the light called Christmas light is not available anymore.

I have successfully removed it from FEIT app and also removed it from Google home.


I'm not able to remove this device from the bedtime routine and so every time I run the bedtime routine it errors out saying this device is not available.



Unlike other devices, when I touch/ click on Christmas lights, it does not open the menu where you usually see the delete option.


Please advise how can I remove this device from the routine. Here is a screenshot attached for the reference. 


1 Recommended Answer

Community Member

I just tried goodnight (as one word) and it let me add that for a custom household routine.  Ridiculous that we are dealing with any of this, but I feel your pain on being notified every night that a device is not available.


View Recommended Answer in original post


Community Specialist
Community Specialist

Hey Moody_Nest,


Thanks for visiting the Community.


I know how challenging it is when you're having issues removing some actions on routine from the Google Home app. Let's go ahead and unlink and re-link your FEIT from the Google Home app. Then uninstall and reinstall the app to see if there are any changes in that routine. Also, could you check if the device still appears in your account. Click here and make sure to log in to the same account linked on your device.


Let me know how it goes.




Community Member

Hello Muddi, 
Thanks for trying to help.
I tried unlink & link FEIT from the Google Home app.
I even tried deleting the home and creating a new Home (reconfiguring all the IOT-controlled lights and nest thermostat). I even tried setting up a new switch with exact same name (Christmas light) but NO LUCK.

New Google Home is a certainly a clean start with setting all other routines from scratch, I can say so because I no more hear "one or more devices are unavailable" when I ask google to turn off everything,
however, the Bedtime routine is still stuck with the action "Christmas lights" I am neither able to delete and recreate the bedtime routine (no delete option) nor I am able to edit the "Christmas lights" action.

I am out of ideas to try now.

I am equally baffled by the blocked option to remove the “Christmas Lights” device from the routine.

But, I can explain why the Bedtime Routine is bulletproof (although I would prefer it wasn’t).  Google has locked in several core routines that they feel are critical to all users, such as Home/Away/Bedtime/Commuting…etc.  They are annoying and clutter the system, but none of them can be deleted.  


They can be made “Inactive” though, which will keep it from responding to any prompts you give.  You can then add your own personal routine (I just noticed they are now Automations instead of Routines) to function as a Bedtime automation, but with triggers and actions only specified by you.

Thanks, hirsch22  for the response.
I had tried adding my own personal routine, but standard triggers/keywords are reserved for standard routines.  e.g you can not use Good Night or Bedtime to trigger your personal routines.

Community Member

I just tried goodnight (as one word) and it let me add that for a custom household routine.  Ridiculous that we are dealing with any of this, but I feel your pain on being notified every night that a device is not available.


Community Member

ok so I was searching the forum a couple days ago as I have a similar problem to you. I was actually going to send this reply on another post that was closer to my problem but i can’t find their post and it’s so exciting to find a solution to such a dumb annoying problem that I have to tell EVERYONE anyway. I really hope it works for you…


I followed everyone’s advice about resetting, unlinking and syncing etc. but I really didn’t want to delete my home app and set everything up if I didn’t have to. After nothing working I resigned myself to deleting the app and to optimise success rate I went into the troublesome routines and deleted every action I could first. Dude. Dude. Dude. I have a time delay!!! Deleting the time delay deleted the action contained in it!! DELETING THE TIME DELAY DELETED THE ACTIONS IN IT!!! I know you don’t have a time delay (well it doesn’t look like it) but maybe if you add it, move the stupidest devices to that section and then delete it will work? I really hope so!! I’ve got my fingers and toes crossed over here for you 

+52492 215 1812