cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Cam with Floodlight setup fails at very end

Scottwilson26
Community Member

I have a nest cam with Floodlight. It has worked for months with no issues. It stopped sending notifications. I changed settings in the Home app with no results.  Forum suggestion was to reinstall the device.  I removed the device from Home app and it would not reinstall. Here is what I have tried multiple times using 2 different android devices.

1.  I reset the device by pushing the reset button until flashing yellow and head the tone.

2.  I rebooted my router.

3.  I uninstalled and reinstalled the Google Home app.

4.  I setup a new home within the Home app. 

5.   When I try to install the device. The setup goes all the way through the process including showing a live feed to adjust the camera. I click next and it says "you're all set".  Then, it asks to record video, record audio, opt in to google diagnostic assist.  Then it says finishing device setup.  Then I receive a message statating something went wrong setup is taking too long, retry or cancel.

I have retried several times.

When I cancel, the flood lights work fine from the app. However when I touch the camera icon, I receive the message "this video stream can't  be viewed here."

1 Recommended Answer

Chris4good
Community Member

It is on the same network (of course).
As an update, I did a complete factory reset/disconnect for the 4th time (literally) and for some reason it is now working.  I'm happy it's working, but that was a super crappy process (on a ladder and in the sun).  No steps were different from the first three times I did the reset, but I did it the 4th time anyway, and it actually worked.  I'm reluctant to buy more of this product given how unflattering the software setup experience was as a compliment to the hardware.
Hopefully, others won't be equally frustrated/demoralized by the mess of it.
Chris

View Recommended Answer in original post

13 REPLIES 13

br459jr
Community Member

I have a very similar issue except I am setting my nest floodflight up for the first time. I can get through all of the setup except for the last part when it says "getting your device ready. This may take a minute.". After a minute I get "something went wrong. Setup is taking longer then expected." I am on android if that helps. 

I'm having the same problem for setting it up for the very first time.

Dingo
Community Member

I am having the same issue, I can't add any devices to my home

Technomoly
Community Member

Same issue, but with the Cam Battery, non floodlight. Tried all of your above, now have a bunch of half-installed camera tiles that I can't remove. Installed the same type of camera 5 days ago without issue. Something has changed.

Hiegear
Community Member

Same here. New camera with flood light. 

McFly99
Community Member

Having the same issue with Google nest flood light. Connection goes in and out for camera and then whole light disappeared from app. Can not get it to rejoin and trying to add it always fails. Light is hard wired and the motion sensors still work for light. Camera light is green but will not connect again. 

janthadeus
Community Specialist
Community Specialist

Hi folks,

 

We’re sorry for the trouble here. No worries, we’ll check this out. What’s the status light of your Nest Camera with Floodlight? How far is the camera from the router? Do you have an Android or iPhone? Do you have mesh WiFi points? Are there devices or appliances (such as baby monitors, microwaves, cordless phones, etc.) near the camera? Also, what WiFi frequency band do you try to connect to (2.4 GHz or 5 GHz)?

 

Going over the steps here might help:
 

  1. Close all the apps running in the background of your phone, reopen the Google Home app then try pairing it again.
  2. Bring your phone closer to the camera within 10 to 12 inches during pairing setup.
  3. Restart your router or modem, unplug it from the power outlet, wait for 1 to 2 minutes then plug it back in.
  4. Factory reset your camera, when the light pulses blue it means it’s ready to be paired to your Google Home app. Try the pairing setup again.

Let me know how it goes.

 

Thanks,

JT

I have done what was suggested.  No change in result.  Stuck at the point that it asks me to click "finish setup"

Brad
Community Specialist
Community Specialist

@Chris4good

 

When you are trying to complete the setup, is the device you're installing it on, connected to the same Wi-Fi connection as the Nest camera with floodlight? Meaning, if you have a dual-band router, is everything connected to the same channel as a 2.5ghz or 5ghz channel? Please let me know.

 

Best regards,

Brad

Chris4good
Community Member

It is on the same network (of course).
As an update, I did a complete factory reset/disconnect for the 4th time (literally) and for some reason it is now working.  I'm happy it's working, but that was a super crappy process (on a ladder and in the sun).  No steps were different from the first three times I did the reset, but I did it the 4th time anyway, and it actually worked.  I'm reluctant to buy more of this product given how unflattering the software setup experience was as a compliment to the hardware.
Hopefully, others won't be equally frustrated/demoralized by the mess of it.
Chris

Brad
Community Specialist
Community Specialist

Hi there,

 

Happy to hear that this has been resolved for you! It looks like we can consider this one complete, so I will lock the thread shortly unless I can help out with anything else.

 

Best regards,

Brad

Ebedia
Community Specialist
Community Specialist

Hello Chris4good,

 

Awesome — glad to hear that and thanks for getting back to us. We'll then go ahead and lock this thread after a day. If you have any new issues, updates or just a discussion topic, feel free to start a new thread in the Community.

 

@Brad and @janthadeus I appreciate your helpful response.

 

Regards,
Emerson

Chris4good
Community Member

I have a flood light that cannot connect due to being unable to finish the set up. So frustrating.