cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Camera Live Video not working

JamesE
Community Member

Nest camera live video doesn't work (shows as either unavailable or connects, but just shows a black screen) on Gen 2 Nest Camera (indoor, connected to power), but weirdly video history works completely fine (i.e. you can go into history and watch a video of yourself being frustrated).

I've tried:

  • Deleting it from Google Home and reinstalling it
  • Unticking the two checkboxes within Nest Wifi Settings (as recommended elsewhere)
  • Moving it to different power points
  • Having it right next to the router

I run a Nest wifi mesh in my house, with Australian Broadband NBN with 1gb download and 50mb upload (seen through the Nest Wifi)

My gen 1 Nest Camera (that works through the Nest Home app, works fine). 

1 ACCEPTED SOLUTION

MrL22
Community Member

SOLVED FOR ME.

Hi All,

Thank you for your assistance and suggestion. 

I wanted to feedback to everyone that after trying so many things, I was able to resolve the issue. 

I run a Ubiquiti mesh set up in my home. Ubiquiti has a feature where it merges 2.4Ghz and 5Ghz under one name (SSID). What I did was to delete this configuration and create two separate Wifi networks, one called Ubiquiti on the 2.4Ghz range, and another called Ubiquiti_5G on the 5Ghz range. I then connected the cameras to the "Ubiquiti" network (2.4Ghz) and it did not only work straight away and every time I load the app, the camera set up a lot quicker in the app.

This may help anyone else who has a 2.4/5Ghz router but only see's a single wifi network in their wifi list.

I hope this helps everyone else to get closer to solving their issue.

Thanks again,

Richard

View solution in original post

64 REPLIES 64

Gnlca
Community Member

I have the same issue 😞

Gnlca
Community Member

Maybe I should have mentioned, that I don't use the Nest wifi mesh.
Also I only have one Nest cam indoor wired 2nd gen.

FAOGozalo
Community Member

I'm having a very similar issue. Also on a Google Mesh netwotk with a Google (Nest) Door Bell (Battery). Everything works and I can actually test the speed on the camera but can't get Live Video to work at all. Any help would be gratefully appreciated

digdigd
Community Member

Same issue. Has anyone been able to resolve this issue?

Hi digdigd,

After doing 3 full factory resets, everything is working as it should. Previously, whilst on the set-up stages I would not get a feed from the camera but on the last attempt I did and everything started working as expected. Remember to disable the Wi-fi preferences if you are using a Google Wi-fi router.

How do you disable the WiFi preferences? 

Brad
Community Specialist
Community Specialist

Hi there, 

 

I apologize for my late response and thank you for all of your patience while waiting for a reply. I definitely understand how frustrating your situation must be, and I wanted to make sure that your concern was acknowledged. Do you still need help with this issue?

 

Best Regards, 

Brad.

JamesE
Community Member

Yes - the live feed still doesn’t work. There isn’t a solution yet. 

Brad
Community Specialist
Community Specialist

Hey folks.

 

I am afraid this is a known issue. No solution at this time, but we are still actively looking into it.

 

Best regards,

Brad.

Alaama
Community Member

Please let us know when a solution is available. Thank you in advance.

JamesE
Community Member

Why can’t we get a refund since the product clearly doesn’t work. 

Alaama
Community Member

I have the same issue !

Any solution ?

JamesE
Community Member

Not yet… bit ridiculous hey

Brad
Community Specialist
Community Specialist

Hey there,

 

Restarting and factory resetting your Google Nest camera or doorbell will have different results:

 

Restart: Keeps all your settings, and it should reconnect to the same Wi-Fi network. This is helpful if it ever becomes frozen, has trouble reconnecting to the internet, or isn't working normally.

 

Factory reset: Erases all your settings and options, and restores its factory default settings. It will not automatically reconnect to Wi-Fi and you'll need to set it up again.

 

You can find this information, plus additional information on this process here. Please let me know if you have further questions.

Best Regards,

Brad

Alaama
Community Member

Hi Brad. Thank you for sending the information but I have tried this already for both my Nest-Cams and it doesn't change the issue.

When trying to view the live feed the audio is working but not the video and then message indicates that it can't connect to cam...

87john
Community Member

I bought this for a reason, to be able to see live video. Is there a fix yet?

87john
Community Member

How do I go about returning this and get my money back?

Brad
Community Specialist
Community Specialist

Hey folks,

 

There was a recent app update. Are you still experiencing this issue after updating and restarting your cams?

 

Best regards,

Brad

My last update of the Google Home app was the end of May and still the same

Brad
Community Specialist
Community Specialist

@markwilliams82

 

There was one that has been rolling out a couple days ago. Please wait for the update, check for it and continue from there.

 

Best regards,

Brad

Still waiting for the update, is there an ETA on when the app update will be out that will hopefully fix this issue that has been going on too long now?

Brad
Community Specialist
Community Specialist

Hi there,

Just checking in to see how the conversation is going as there's been a lapse in activity on this thread.

Best regard,
Brad

LJG
Community Member

Still a problem. App version: 2.53.1.5

Seems to especially be an issue with Google Home wireless (battery) cameras + Google Mesh Wifi (yes, we've unchecked app preferences).

Alaama
Community Member

I have indeed also a Google Mesh Wi-Fi. Thinking it should work better all together... It would be interesting to know if the others experiencing the problem have also the Google Mesh Wi-Fi.

Brad
Community Specialist
Community Specialist

Hey folks,

 

Thanks for sharing all of this great information! I will invite y'all to send in feedback on this issue as at this time, I am not aware of a solution. All the information here could be helpful in finding a solution for all. I just wanted to jump in real fast and thank you for your feedback. Please feel free to submit your feedback to us. I've put instructions for feedback below.

 

  • Open the Google Home app

Google Home app

  • At the top right, tap your account.
  • Tap Feedback 

and then

  • tap the type of device you'd like to submit feedback for.
  • To display available emails, in the "From:" section, tap the arrow on the right. Select your email address.
  • In the feedback summary, write a brief description of your issue.
  • Be sure to check the box for Screenshot and System logs.
  • To submit feedback, at the top right corner, tap Send 

 

If you need anything else, please let me know.

Best regards,

Brad

Brad
Community Specialist
Community Specialist

@Robin2022

 

If you are having issues with your Nest Cam or Nest Doorbell, I would suggest that you first start by restarting it. 

 

Restart: Keeps all your settings, and it should reconnect to the same Wi-Fi network. This is helpful if it ever becomes frozen, has trouble reconnecting to the internet, or isn't working normally.

 

Best regards,

Brad

markwilliams82
Community Member

2 weeks for a known issue and no fix is pretty poor to be honest considering how many people it seems to be affecting and also how it's affecting one of the whole reasons for having the cameras 

ldevlieg
Community Member

I thought it was my camera, I'll hang out until I see the solution (or not)....

PIN58
Community Member

I have spent hours on the phone w/NEST for the same issue for 4 weeks. Still no resolution. This is poor customer service!  

markwilliams82
Community Member

It is!

I raised this, spoke to support and was told I'd be referred to senior support but no change.

Just told its an issue they know of but the issue has been known for a long time by several users 

Bertlamb
Community Member

I also have this same issue on a newly installed nest cam with flood lights. I could connect to live view after installing but now a day later no live view connection but history works fine and I get notified about events

Brad
Community Specialist
Community Specialist

Hey there,

 

If you are having issues with your Nest Cam or Nest Doorbell, I would suggest that you first start by restarting it. 

 

Restart: Keeps all your settings, and it should reconnect to the same Wi-Fi network. This is helpful if it ever becomes frozen, has trouble reconnecting to the internet, or isn't working normally.

 

Best regards,

Brad

Alaama
Community Member

Hi Brad. Thank you for your assistance. I've tried that and it didn't solve the problem... still got the live audio during connection attempt but it stops after a few seconds during connection attemp with message that live video not possible.

Brad
Community Specialist
Community Specialist

@Alaama

 

It sounds like you have some internet issues then. Restart your internet modem/router, and then restart the camera.

 

Best regards,

Brad

Christianjf
Community Member

I've done all the steps everyone's suggested and still nothing. Internet is perfect. I can hear audio but no live video.

Robin2022
Community Member

I am also having same issues. Just purchased 4 new battery cameras. No live feeds available. I can hear sound but no live feeds.  The nest app had perfect live feeds. This app is terrible so far. 

MrL22
Community Member

I have just bought two cameras and with no eta on the live feed issue being fixed, I am tempted to send them back and go with someone else. Shame really as I would like to keep everything in the Google eco-system.

Brad
Community Specialist
Community Specialist

@LJG

 

Where did you find this information? I would honestly be interested to know where you saw that. As far as I am aware, it's usually an internet issue of some sort. I would suggest that you reach out to Support to work with them on this issue.

 

Best regards,

Brad

LJG
Community Member

where did I find the app version? In the Google Home app, About.

I have the older Google Mesh Wifi at home and my wired cameras are fine but my wireless doorbell will occasionally not connect for live feed (they still record activity, I just can't connect for live feed).

Last year I helped a friend setup NEW Google Mesh Wifi in their home, 2 wireless outdoor cameras and 2 wireless doorbell cams. Until very recently, they were able to stream a live feed from cameras but now they also receive "cannot connect to camera" errors.

I believe it to be possibly a result of an update or something since it was working and now is NOT working (or works intermittently) regardless of signal strength, etc.