Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

"Can't connect to assisting device"

Community Member

I purchased the Google Nest Cam 2 Pack. Installed the first one in the Google Home app with no problems whatsoever, went to go install the second one and was met with the "Can't connect to assisting device" error. Doesn't matter what I do, I cannot get past this screen. Tried an iPhone, and Android, tried turning off the dual-band wifi so everything was on 2.4ghz, tried putting the cameras beside each other, nothing works. 


2 Recommended AnswerS

Community Member

I had the same issue. I just disconnected the camera I had initially setup and then setup up the camera I was having trouble with. After that camera was good to go the second camera was able to connect. Hope this helps!

View Recommended Answer in original post

This solution worked for me as well. Same problem here. I bought 2 nest cams and a doorbell. Couldn’t install anything past the first camera.

I removed the camera from the Google Home app, installed the doorbell properly, then came back to re-install the camera.

you will still briefly see the “connecting to an assisting device” screen, but it freezes and jumps to the following one and everything works fine.

I left both charging now. God knows what’s going to happen tomorrow when I try to install the second camera.

View Recommended Answer in original post

161 REPLIES 161

Community Member

The accepted solution (of removing the first device in order to get the second device on WIFI) worked for me with two Nest thermostats I was installing.

After removing the first one I have to go into its settings and choose the "disconnect account" icon. It will warn you that you'll lose all your settings and just say yes. After clearing the settings and rebooting itself I was able to add it back.

Longer explanation:

So in essence I had to basically setup the Nest thermostat 3 times choosing the same heating/cooling presents and same schedule 3 times just to install 2 thermostats because for whatever reason on the second thermostat it couldn't use the first thermostat to setup the second...

So removed the 1st, setup the 2nd then went back to setup the 1st again. iPhone couldn't connect to the 1st this time and the instructions recommended resetting the thermostat which led me to my deleting the account on the thermostat itself (the 1st one) in order to get them both working.

I'm wondering since there was probably 30 mins between setting up the 1st and the 2nd that causes Google to crap itself. I don't know but not a great first impression.

I compare this experience to setting up my Ring doorbell, Ring bridge and Ring lights (at different times) where there was not a single problem and I now regret not going with Amazon for my thermostats; it's just the recommended thermostats for Amazon didn't look as sexy as the Nest.

Community Member

I just bought two cameras and neither will install get the message "can't connect to assisting device".....very disappointing