cancel
Showing results for 
Search instead for 
Did you mean: 

4k ultra

JCobra
Community Member

Just moved and want to update Chromecast to new wifi network. Factory reset it because I couldn't update it. Now I can't get it going cause it says needs activated before setup. Help!

1 Recommended Answer

davidking
Gold Product Expert
Gold Product Expert

iPhone uses a different setup process, so you shouldn't be seeing the "needs activation" error. If you're able to use an iPhone, try these steps:

  1. Factory reset Chromecast to start afresh
  2. Make sure your Chromecast is within 15 - 20 ft (4 - 6 m) of the Wi-Fi router. If you have a dual band router, try to set up your device on both the 2.4 GHz and 5 GHz bands.
  3. Make sure Wi-Fi and Bluetooth are both turned ON on the iPhone.
  4. Turn OFF mobile/cellular data.
  5. In iPhone Settings > Privacy & Security > Local Network > Enable Google Home.
  6. Setup Chromecast

 

View Recommended Answer in original post

15 REPLIES 15

davidking
Gold Product Expert
Gold Product Expert

JenniferV
Community Specialist
Community Specialist

Hey there,

 

Thanks for the help here, davidking. I appreciate it.

 

JCobra, we hope that helps. Feel free to let us know if you still need help or have other questions and concerns — we're always here for you.

 

Regards,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hi JCobra,

 

It's me again. I wanted to check if you still need help. Don't hesitate to reach back if you do.

 

Best,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hello there,

 

Just checking in to make sure that you've seen our response. Please let us know if you have other questions or concerns as we will be locking this in 24 hours if we won't hear back from you again. Feel free to start a new thread and we'll be happy to help.


Thanks,

Jennifer

JCobra
Community Member

Thanks David but that's what got me here.

JCobra
Community Member

Doesn't solve the issue 

davidking
Gold Product Expert
Gold Product Expert

What device are you trying to use to do the setup and what country are you located in?

JCobra
Community Member

Chromecast Ultra in the US. I tried the chat and it's been over a week with no response.

davidking
Gold Product Expert
Gold Product Expert

And what phone or tablet are you using to do the setup? Do you have another one you can try the setup with instead? If it's a Pixel phone, do you have a non-Pixel phone you can try setup with? Perhaps one from a friend or family member?

JCobra
Community Member

I only have a pixel phone.

JCobra
Community Member

I tried from an iphone but same results.

davidking
Gold Product Expert
Gold Product Expert

iPhone uses a different setup process, so you shouldn't be seeing the "needs activation" error. If you're able to use an iPhone, try these steps:

  1. Factory reset Chromecast to start afresh
  2. Make sure your Chromecast is within 15 - 20 ft (4 - 6 m) of the Wi-Fi router. If you have a dual band router, try to set up your device on both the 2.4 GHz and 5 GHz bands.
  3. Make sure Wi-Fi and Bluetooth are both turned ON on the iPhone.
  4. Turn OFF mobile/cellular data.
  5. In iPhone Settings > Privacy & Security > Local Network > Enable Google Home.
  6. Setup Chromecast

 

Jeran
Community Specialist
Community Specialist

Hey there JCobra,

I'm just checking up on this thread, did you have any more questions or need any additional help? 

Thank you for helping out on this thread, David!

Best regards,
Jeran
 

JCobra
Community Member

No more questions. I decided to factory reset all devices and everything is up and running.

Thank you

Jeran
Community Specialist
Community Specialist

Hiya JCobra,

 

No problem at all! In that case, I'll go ahead and lock the thread. If you had any more questions or concerns in the future, please feel free to create a new thread.

 

Best regards,

Jeran