cancel
Showing results for 
Search instead for 
Did you mean: 

Cant connect chromecast

Kayte
Community Member

Let me start off by saying I have no idea what generation of chromecast I have, it doesn't say anything about that on the box. 

I am trying to connect my chromecast to my TV using the home app. Everything goes fine until the connection screen, then I get an error:

Screenshot_20221227-111534_Home.jpg

I have restarted my phone, my chromecast, and my router. Still won't work.

1 Recommended Answer

Kayte
Community Member

I got it working. I had to split my wifi so u could run it of the 2.4 instead of the 5G

View Recommended Answer in original post

6 REPLIES 6

davidking
Gold Product Expert
Gold Product Expert

It sounds like you've already tried some of these steps, but I'll include them all in full!

  1. Make sure your Chromecast is within 15 - 20 ft (4 - 6 m) of the Wi-Fi router. If you have a dual band router, try to set up your device on both the 2.4 GHz and 5 GHz bands.

  2. Make sure Wi-Fi and Bluetooth are both turned ON on your phone or tablet.

  3. Turn OFF mobile/cellular data.

  4. Reboot your router. Most routers just require that you unplug the power source and then plug it back in to reboot.

  5. Reboot Chromecast by removing the power cable, then reconnect it.

  6. Make sure you're using the latest version of the Google Home app, by checking your app store for any updates.

  7. Restart the Google Home app.

  • Android: Swipe up from the bottom, hold, then let go. Swipe up on the Google Home app.
  • iPhone/iPad: Swipe up from the bottom, hold, then let go. Swipe up on the Google Home app. On older devices with a home button, double-click the Home button, then swipe up on the Google Home app.
  • Turn Wi-Fi off and on again on your phone or tablet.
  • Reopen the Google Home app.

If none of the steps above help, factory reset your Chromecast and then retry setup. You may also want to try setup using a different phone or tablet, just to test, if you have one.

JenniferV
Community Specialist
Community Specialist

Hey there,

 

Thanks for the help here, davidking.

 

Kayte, we hope that helps. Feel free to let us know if you still have concerns. We're always here for you!

 

Best,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hello Kayte,

 

It's us again. We want to check if you still need help. Let us know if you do.

 

Thanks,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hi Kayte,

 

Just checking in to make sure that you've seen our response. Please let us know if you still need help or if you have other questions or concerns as we will be locking this in 24 hours. Feel free to start a new thread and we'll be happy to help.


Regards,

Jennifer

Kayte
Community Member

I got it working. I had to split my wifi so u could run it of the 2.4 instead of the 5G

JenniferV
Community Specialist
Community Specialist

Hey Kayte,

 

Awesome! Glad to hear that this has been sorted out and thanks for keeping me in the loop. Let me know if you still have questions and concerns otherwise, I'll be locking this thread after 24 hours. 

 

Best,

Jennifer