cancel
Showing results for 
Search instead for 
Did you mean: 

Chrome cast no lights on remote

Kerrieboyd
Community Member

Brand new chrome cast and remote led blinks twice when batteries put in but can’t get it to do anything at all. Voice control won’t start so can’t even get to set up on tv.

4 REPLIES 4

davidking
Gold Product Expert
Gold Product Expert

If you're happy the batteries are good (try them in another device to test), try these steps:

  1. Remove the batteries from the remote.
  2. Hold the home button on the remote down and re-insert batteries while holding the button down. 
  3. The remote should be detected on the right side of the screen.

In most cases, your remote will pair automatically after you insert the batteries. If it doesn’t, follow the steps on the TV screen, or press and hold the Back and Home buttons on the remote for 3 seconds.

JenniferV
Community Specialist
Community Specialist

Hi there,

 

Kerrieboyd, we hope that helps. Feel free to let us know if you still have questions. We're here to help!

 

Thanks for the help here, davidking.

 

Regards,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hello Kerrieboyd,

 

It's us again. We want to check if you still need help. Feel free to let us know if you do.

 

Best,

Jennifer

JenniferV
Community Specialist
Community Specialist

Hey Kerrieboyd,

 

We haven't heard from you in a while so we’ll be locking this thread after 24 hours. If you're still experiencing problems, please feel free to start a new thread and we'll be happy to help.


Thanks,

Jennifer