cancel
Showing results for 
Search instead for 
Did you mean: 

C by GE Bulbs & Plugs Constantly Disconnecting

MsSwiftFarrow
Community Member

I have 10 C by GE Smart Bulbs and 2 Smart Plugs in my home and they all constantly are disconnecting and reconnecting. I have Bond Home smart fan and light and it never has this issue and works fine, even when C by GE doesn't work in the Home app, speakers or via assistant. This has been happening for me at least a year and in the past month, at least once a day. I have reset all of my bulbs and plugs countless times in the past year, and it works, until the next day or so when it is intermittent again. I've submitted feedback in the home app as well as to GE multiple times. 

3 REPLIES 3

twittel
Community Member

LOL...have you rebooted your wifi router, and turned the bulb off for 8 seconds, then on for 2 seconds?  LOL...I'm done with GE Smart Bulbs and use KASA switches and plugs.

BJBosche
Community Member

I believe I have found the answer. Factory reset all of the bulbs and devices THEN reconnect them to your system using the Cync app (the native app for the C by GE bulbs). Make sure they are connecting via WiFi, NOT Bluetooth. After connecting each device, transfer the control to the Google Home app. I did this 2 weeks ago and have only had 1 issue when the Cync servers were being updated (about 30 minutes). I didn't need to do anything then to restore functionality.

GarrettDS
Community Specialist
Community Specialist

Hey folks,
It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread.

Have a great day.
Garrett DS