cancel
Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can't add my child to Google Home Hub WiFi error in Family Link

Giebnatious
Community Member

Last Christmas we bought my daughter a home hub for her room. I remember it took awhile and was frustrating it eventually we got it to where she could connect to it and control it. Since then we have moved and now we can't get her connected to it. We've tried uninstalling updates for the Home app and we still get the WiFi error. We go to Home, settings, assistant, parental controls and eventually after we click our daughter's profile and devices it says they are offline. We've tried turning data off on our phones and are on the home WiFi that is the sole WiFi in the house. Our daughter is under 13 so we can't even let her set it up as her own home device. This is the most frustrating and infuriating thing for all of us! I love Google products but seriously!? I just want my daughter to be able to use the Hub we bought her like she was before we moved.

12 REPLIES 12

David_K
Platinum Product Expert
Platinum Product Expert

If you've already changed to a different Wi-Fi network, try these steps:

  1. Open the Google Home app.
  2. At the top left, tap Add + > Set up device > New device > set up new devices in your home.
  3. Follow the in-app steps.

If these steps above don’t solve the issue, you’ll need to factory reset your speaker or display, then set it up again using your new Wi-Fi network and password.

Instead of factory resetting your speaker or display, if you're comfortable changing your router settings, you can change your new Wi-Fi network name and password in your router's settings to be the same as the previous ones. Your device should then automatically connect to the Wi-Fi.

Once the Wi-Fi is changed or you've reset it and set it up again, you can follow the same steps you did originally to add your daughter's account and configure settings.

Let your child use Google Assistant on your devices - Google Nest Help

I've tried that. We have reset the device multiple times. I can add it to the home app but it stays connected to all of my account and won't switch to hers. Before we moved she could control it. Her Spotify was linked, her Meet. Now she can't do anything. I was able to add her to it (the devices only show available on my old phone even after logging out of my account on it. Aka the WiFi error still shows on my new phone when trying to add anyone in the family to a device under assistant settings). In her Home app under the device there is a request to join this home but when you do that it gives the failed error every single time. When Google devices work they are amazing. However, getting to that point is hands down one of the most frustrating and infuriating things in the world. I'm getting really close to getting rid of every Google device I own except for our Pixels just because basically every other phone is trash. 

David_K
Platinum Product Expert
Platinum Product Expert

Setting this up can be tricky! On your new phone, let's check a few things:

The display is successfully setup with your account and you can see it in the Google Home app?

Assuming that's the case, once setup, you followed these steps to add your child's voice to the device?

  1. Open the Family Link app on your phone.
  2. Select your child.
  3. Tap Controls > Content restrictions > Google Assistant > Add your child to new devices.
  4. Select the display if you see multiple devices.
  5. Follow the on-screen instructions to sign your child in.
  6. Hand the phone or tablet to your child.
  7. Help them teach Google Assistant to recognize their voice.

As for linking Spotify and Google Meet, you can do that in the Google Home app settings:

  1. To add Spotify, tap Settings > + Add > Service > Music > Spotify.
  2. To add Google Meet, you should be able to do that with these steps.

Following those steps in Family Link doesn't work unless I need to retrain or remove voice match for my daughter. Otherwise I get to step 1 of the setup and then it says complete.

Also, I still can't do the previous action on my new phone (Pixel 7a). I was able to add her via the Home app on my old phone (Pixel 5). Even after signing out of my accounts on my old phone, I still get the devices need to be connected to the same wireless network or some devices are offline when trying to do it on my new phone. I believe we have it set to where it is basically completely her device but things clearly are still kot working as they should be.

David_K
Platinum Product Expert
Platinum Product Expert

Try uninstalling the Home app on your Pixel 7a, power off your phone, wait 30 seconds, turn it back on again and reinstall the app. Make sure you sign into the same account you used on your Pixel 5 and your phone is definitely connected to the same Wi-Fi network as your devices. If it still shows devices as offline then power off your devices and power off your router (and modem if you have one), wait 30 seconds, then turn your router and modem back on again. Once back online, turn on your devices again.

As for the voice match setup, what do you see if you:

  1. Open the Family Link app.
  2. Select your child.
  3. Tap Controls > Devices.

Does it show the display here as linked to your daughter's account/voice?

If not, let's clear her account/voice from all devices to sort of reset this so you can try again:

  1. Select your child in the app.
  2. Tap Controls > Content restrictions > Google Assistant > Remove Voice Match or Remove Voice Match & Face Match > Remove.

You should then be able to set it up again with the display with the steps I shared in an earlier reply.

The device does show linked to her account/voice now after connecting her via my Pixel 5. 

I am currently away from home so I can't test the steps to see if it works for my Pixel 7a. I will test it out later this week when I am back home.

LovelyM
Community Specialist
Community Specialist

Hi Giebnatious,

Sounds like a plan! We'll keep your thread open for a few more days until you try this out. Just give us an update once you're able to test out the suggestions provided by davidking.

Sincerely,
Lovely

Juni
Community Specialist
Community Specialist

Hi there,

 

I just wanted to follow up to see if you still need our help. Please let us know, as we would be happy to answer any questions you may have.
 

Thanks,

Juni

Giebnatious
Community Member

Hello Juni,

     It appears that everything has worked itself out. I am now able to see all the devices as expected. A big thank you to you and the rest of the team for all the help.

V/R,

Giebnatious 

David_K
Platinum Product Expert
Platinum Product Expert

So glad to hear that, have a great weekend!

Juni
Community Specialist
Community Specialist

Hi folks,

 

As we got our resolution here, I'm going to mark this one as resolved. Please feel free to open up a new thread if you need assistance.
 

Thanks for the help here, davidking.

 

Cheers,

Juni

Muddi
Community Specialist
Community Specialist

Hey Giebnatious,

 

I hope we were able to answer your question with the info provided by @David_K. If you have additional questions, feel free to respond to this thread and we'd be happy to further assist you.

 

Cheers,

Muddi