cancel
Showing results for 
Search instead for 
Did you mean: 

Can't cast explicit music to speakers

markkelly
Community Member

I can't cast explicit songs from YouTube music to any of my google speakers.

The content filter in YouTube music is not on.

Also if I try to ask the Google assistant to play an album and not a song, it doesn't play the album; rather it plays a random YouTube playlist.

3 Recommended AnswerS

Cathal_S
Gold Product Expert
Gold Product Expert

Can you try first requesting the song played and then afterwards try casting it and let us know if that works?

 

Regards,
Cathal

View Recommended Answer in original post

Yeah that seemed to work. I can now cast any explicit song. Thanks

View Recommended Answer in original post

Cathal_S
Gold Product Expert
Gold Product Expert

Hi again,

If I use your command I get a YouTube video (on my Nest hub) but if I say "Hey Google, play LP3 by hippo campus" then it plays the album correctly.

Can you give that command a try and see if that works, "Hey Google, play LP3 by hippo campus".

Edit: you don't need to say the word 'album' in your commands. Just use the format....

 

"Play [album name]"

Or

"Play [album name] by [artist name]"

 

Regards,
Cathal

View Recommended Answer in original post

12 REPLIES 12

Cathal_S
Gold Product Expert
Gold Product Expert

Hi markkelly,

Please check that you don't have any digital wellbeing filters on that could be filtering what can be played.

https://support.google.com/googlenest/answer/7084229 

Do you have a subscription to YouTube premium? This can effect what music is played.

 

Regards,
Cathal

Hi Cathal,

There are no filters under digital wellbeing.

I have a YouTube music premium subscription.

Another thing that stopped working in the last few days is if I ask the speaker to play a radio station, it says 'playing today FM on tunein' but then there is just silence. This only stopped working in the last week.

The issue with the explicit songs not casting has been happening for about a year or more.

Thanks,

Mark

 

Cathal_S
Gold Product Expert
Gold Product Expert

Hi again,

There is an issue with some TuneIn radio stations currently that is being investigated.

Is the Google account that you are using for YouTube and your Google devices aged over 18?

 

Regards,
Cathal

Yeah its an over 18 account. 

If I ask the assistant to play an explicit song it will play it via YouTube music.

But if I cast it from the app it doesn't work.

I have 3 speakers - 2 mini ones. If I try cast to the mini speakers it says "something went wrong" and skips to the next song

Cathal_S
Gold Product Expert
Gold Product Expert

Can you try first requesting the song played and then afterwards try casting it and let us know if that works?

 

Regards,
Cathal

Yeah that seemed to work. I can now cast any explicit song. Thanks

Cathal_S
Gold Product Expert
Gold Product Expert

Thanks for testing and reporting back.

As you have a YouTube premium subscription you should be able to request albums to be played.

Can you give us an example request that you are using so I can test on my own speakers.

Music help center:

https://support.google.com/googlenest/answer/7030379 

 

Regards,
Cathal

An example would be:

Play the album LP3 by Hippo Campus

 

Cathal_S
Gold Product Expert
Gold Product Expert

Hi again,

If I use your command I get a YouTube video (on my Nest hub) but if I say "Hey Google, play LP3 by hippo campus" then it plays the album correctly.

Can you give that command a try and see if that works, "Hey Google, play LP3 by hippo campus".

Edit: you don't need to say the word 'album' in your commands. Just use the format....

 

"Play [album name]"

Or

"Play [album name] by [artist name]"

 

Regards,
Cathal

Hi Cathal, yeah that worked. If I remove the word album it works. Thanks

Azarco
Community Specialist
Community Specialist

Hey there,

 

Cathal_S You've been awesome assisting markkelly with his concern.

 

markkelly Thanks for updating the Community forum about your resolution. Feel free to respond to this thread if you have additional questions or concerns and I'd be glad to answer it for you.


Thanks,

Alex

Azarco
Community Specialist
Community Specialist

Hi markkelly,

As we got our resolution here, I'm going to mark this thread as resolved. I'll be locking this thread if we won't hear back from you again in 24 hrs. Should that happen, feel free to create a new one if you have more questions or have other concerns in the future.

Best,
Alex