Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can't install my nest. Device did not ask for language settings and network name does not match

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original Poster: Sarah Verhegge 

Hi there!

Yesterday my Google Nest Protect arrived, I was so happy!
Unfortunately I can not install the device.
When I turned it on, it just said 'Hallo', it did not ask for any language setting.
When I try to link the nest to my Iphone, it says 'go to your WiFi settings and connect to network NEST-####
My Iphone does not find this network, it shows another network name, which I tried connecting to but that did not succeed either.
I have already tried to reset the Nest Protect, I already checked my Wifi settings...
I already read every troubleshooting message but I can't find the problem.
Does anyone know what I need to do next?
Thank you so much!