Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Cam for Office

Community Member


I use Nest cams personally at two properties and the app / web interface works great to toggle back and forth.  

Our office uses G Suite and we want to set up some Nest cams there as well.  To avoid cross over with my personal residences, I wanted to use my work based G Suite account as the login for the office Nest Cams.  Google let me purchase a Nest Aware subscription on this account, but when I'm trying to set up the Nest Cam through the app, it says I can't use a G Suite account for this.

Any advice?




Silver Product Expert
Silver Product Expert

Hi @skoles 

I'm not entirely sure, but you might need to reach out to the Admin Console user of your work based G Suite account to turn that ability on.  

Community Member

Thanks MrVaacca!

So went to the G Suite admin console and found how to enable the Nest app for our organization.  I would have thought that would immediate solved the issue.  However, I'm still getting the error message that G Suite accounts can't be used with Nest. 

Any other ideas?

Silver Product Expert
Silver Product Expert you said...that should have fixed the problem.  I've seen in other situations where it will take 24 hours for the changes to take effect, but I am not confident that this is the case with this one.  I sadly don't have any other ideas on what else to trouble shoot 😞 Hopefully someone else will be able to pick this up. 

Community Specialist
Community Specialist

Hi there,


Sorry for my late response. Thank you for all of your patience while waiting for a reply. I just wanted to make sure that your issue is addressed. I am terribly sorry to hear that you have had such a hard time with this! I would love to look into this issue further and help find a solution for you. First off, I have some questions I’d like to ask you.

  • Do you still need help with this issue?

  • What troubleshooting steps have you done thus far? 

  • Have you tried to restart your device if you haven’t already?

  • If the restart didn’t work, have you tried to do a Factory Reset? This would be a last resort option, but would clear out issues and the device would essentially be ‘brand new’

Please let me know if you need further assistance. 

Best Regards,


Community Specialist
Community Specialist

Hey folks,
It looks like we haven't heard back from the OP so I'm going to go ahead and lock the thread. If you have any further questions or concerns, feel free to create a new thread.

Have a great day,
Garrett DS