Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Protect Gen2 Cannot connect to network nor factory reset

Community Member

Hello Google Nest Community. I have a Nest Protect Gen2 (wire free) and I've had it for some time, and ever since I changed Internet Service Providers, I am unable to do anything with it. While it still works as a Smoke Detector, I cannot get it connected to the internet and have information on the device. I've been trying to troubleshoot this problem for what seems like a year.

Edit3/4: Same exact problem as

Here are some things that I've tried that have NOT worked:

  • Factory Reset (I've probably done this like 100+ times)
  • Connect to PC to try to find PLI file. (There was nothing in it.)
  • Create a new home in the Nest app to attempt to see if that works
  • Remove other nest devices from account.
  • Contacted Nest Support in the traditional way (chat and phone-call)
  • Edit: Removed this device from nest account (have not been able to get it to reconnect)
  • Edit2: Put on 2.4GHz network (Always has, always will)
  • (Edit2 still): Used multiple phones on different Operating Systems

I know my nest protect is old and out of warranty, but it still "mostly" works, and I do not want to buy another one as they cost a lot and like I said, this one still "mostly" works.

There may have been some other things that I have tried, but I'll attempt to respond if someone suggests a thing that may ring a bell.


Anyways, I'm looking forward to seeing your responses. Thank You.


Diamond Product Expert
Diamond Product Expert

Hi @dog_ 

Try all the troubleshooting in this link: Can’t connect Nest Protect to the app or Wi-Fi - Google Nest Help   make sure your router is broadcasting 2.4GHz.

If you still have trouble after going through the troubleshooting from that help page please let us know.



Community Member

Tried that already. Also, it's been on 2.4 ever since we owned the product.


I forgot to add that I removed the product from my nest account and I haven't been able to add it back for over a year.

Community Specialist
Community Specialist

Hi everyone,


@dog_, thanks for reaching out here in the Community and for sharing here all the steps you've done. To further isolate this issue, could you try connecting your Nest Protect using your mobile hotspot? Make sure that the phone that you're going to use in this set up should be on the same hotspot as well. Looking forward to your response


I appreciate your help, JillG.




Community Member

Can't even get to that point. It wants to connect to another Nest Protect.

I also just tried a new home instance and same thing, it doesn't even get to that point, nor am I able to force it to go to that point.

Community Specialist
Community Specialist

Hi there,


@dog_ thanks for keeping us in the loop. Please fill out this form as I'll hand it over to our team for more options. Please let me know once you're done. 


I appreciate the help, @JillG and Emerson.




Community Specialist
Community Specialist

Hello dog_, 


We've received your form — thanks for filling that out. I'll consider this post as complete and will lock the thread in 24 hours. Please keep an eye on your email as someone from our team will reach out to you to assist you more.

All the best,