cancel
Showing results for 
Search instead for 
Did you mean: 

6.2-22 Software Update Issues

Neelfsu
Community Member

Is anyone on the 6.2-22 Software version and having issues? My Nest thermostat was updated to the new software last week and since then I have had issues with both shorter cycles and the thermostat running for an extended time (far beyond target temperature). I'm curious if anyone else is having issues. 

I've contacted Google / Nest support and not one person  has any details on the 6.2-22 version and this software version isn't listed on the software version page. 

235 REPLIES 235

csmall
Community Member

Yes, it is 100% related to the Asus router firmware. I can only speak to my Asus model but I imagine they use similar code and firmware for other models.

It was 100% the cause of my connectivity/app issues. 

There may still be other issues with the nest update, but they may be more related to HVAC stuff than connectivity/app.

For anybody wondering if they have a connectivity/app issue, connect your thermostat to a mobile phone hotspot to troubleshoot and see if it works as expected while on the hotspot.

I had no connectivity issues.  My problem was just that the Nest was only intermittently sending heat signals to the furnace and so the furnace was running all day long and not heating the house as others have noted.

 

MonicaH
Community Member

Same still....

 

HK21
Community Member

Help me understand how were you able to get on Guest network when Nest was not able see any Wi-Fi available. May be I. An try that if you can help. 

bradbort
Community Member

I could see wifi networks. I could not stay connected for more than a day before dropping. 

bradbort
Community Member

I meant it solved the connectivity issues. 

Hobbeks
Community Member

I have just found out few more issues.  My Thermostat is NOT holding the Date/Time settings.  This causes the thermostat to come on at the wrong time or turn off at the wrong time.  Also having intermittent charging issues with battery.  Yes I have the C wire with it's 200milli-amp current draw.

 

Afmyers
Community Member

Nest Gen 3 display model 3.4 and since the update on 26 October, have been experiencing short cycling with the furnace. Received error M6 as the furnace turned on and off multiple times within 15 minutes. Tried a factory reset just now and initially got the m15 error but it seems to have cleared itself almost immediately. Hoping this fixes the short cycling issue but if not, will switch to eco bee today! 

Very frustrating as a long time nest customer. Having everything integrated in one app is great so it will be annoying to have to adopt the eco bee too.  

Dsmit
Community Member

Anecdotally, from all these posts, it appears the firmware update 6.2-22 does not play well with Display model 3.4.  It’s working well (so far) with the Display 3.6 that Google sent me.

Afmyers
Community Member

Did they send you a replacement outside of your warranty? Mine is 4 years old now 

Dsmit
Community Member

Yes, it was outside of warranty.  However, it was a unit they had previously replaced, so I don't know if that was a factor.

They never came out and admitted it, but because the hardware was performing just fine before the firmware update to 6.2-22, I think they realize there is a compatibility issue with some versions of the hardware.  Their update triggered the issue and that is *not* a hardware warranty matter.

If they know firmware is not going to work on older hardware, the approach would normally be to stop updating those older units.  I think the incompatibilities caught them off guard and they are attempting to minimize warranty costs by first telling out-of-warranty customers they are out of luck.  I politely and respectfully pushed back and eventually got a replacement unit. 

Keep in mind, the Support people you deal with did not cause the problem, they are just doing their jobs.  Kindness while being assertive about the need for them to address the issue goes a long way! 

Did you short cycling went away 3.6 display? 

I never had an issue with short-cycling.

My problem was that as soon as the firmware updated to 6.2-22, the unit could no longer see any Wi-Fi signals from any type of router or even a smartphone running as a hot spot.  With no connectivity whatsoever, it was still operating the HVAC like an ordinary thermostat.  

Interesting in display model 3.4. I’m the same and having awful short cycling. I switched the upstairs with Honeywell I had lying around and it fixed the issue. Downstairs with Honeywell was still short cycling every 7-10 mins. So I have a HVAC person coming in next week to check it. 
I’m gonna see once he fixes downstairs if I’m still short cycling with nest. But maybe it is 3.4 display + 6.2.22

If you haven't already, try a factory reset on the thermostat itself, then remove it from the Nest app, and re-add it. That seems to have fixed it for me but I've only done a few test runs today over the past couple hours. 

Even if this fixed it, I'm concerned about future SW updates causing the same or other issues that may not be resolved. I'm tempted to call for a replacement to get the updated HW version (display 3.6) but will see how this operates over the next week or so first. If in doubt, I'll swap to an eco bee instead. 

mystery
Community Member

I have 3.6 display and I have issues where the heat keeps running even after turning it off.

Neelfsu
Community Member

Interesting, my main issue is with short cycling, but I also have the 3.4 Display. Thanks for the update, I may try to chat support again.

mystery
Community Member

I am running nest thermostats in two locations. One forced hot air gas furnace with Nest Learning Thermostat. This one keeps running longer than needed and doesnt turn off. The other location has oil radiators and Nest Thermostat E, this furnace keeps cycling on and off. Google really screwed something up.

CaptainJeff
Community Member

I’m finally tapping out of this thread.   Here’s the bottom line: replace them with the $19 Honeywell.   So you’ll have to stand up and walk to adjust your heat and a/c - I guarantee you won’t be writing any blogs about how Google’s solution is just around the corner.   They will not work. 

StevoF
Community Member

Same issues here. At first, the only issue was the Wi-fi connectivity issue. So, I removed the device from the app, reset it to factory, and re-added. Everything added just fine. Now, the fan takes upwards of 10 minutes to start (or stop) when I tell it to, and the heating cycle runs 20 minutes past reaching the targeted temperature. Also, the device tells me the network is not available, but the app says it is. Fix this, Google...and fast. Winter is on the horizon.

mystery
Community Member

I wonder if anyone that actually works for Google has posted in this thread? 

Brian_S
Community Member

StevoF, at this point we are not even sure if the tech team at Google is aware of the problems.  Frustrating!  I have moved on and replaced the thermostat as it's winter where I live.

mystery
Community Member

Hellooooo Google. Are you going to acknowledge/fix?

Earaim
Community Member

Yes, I lost the heat option, no heat blowing at all , worse time for it to go out. everything else works. I will swap it with an older nest gen 1 to see if it solves the problem. I Can’t find a way to revert back to the prior version.

antun
Community Member

Just want to add my name to the many people who are having trouble with this update.

  • I have two Nest Es and one Nest 3rd gen that are all on 6.2-22. They were working fine for 2 years.
  • I can access them remotely via the app (or via home.nest.com) to check status, and I can set the temperature, but they do not activate the heating.
  • They don't glow orange to indicate that heating is happening, and the place does not get warm.
  • The safety temperature setting does trigger the heating. It's just they will not go above the safety temperature.

Google, please fix this.

Revil
Community Member
  • I’m still having the same problem. 

xCommando
Community Member

Mine is a nest learning 3rd gen. Lost wifi but will work manually, however it will continue heating/cooling past set temp and the battery doesn't want to stay charged anymore.

gwade
Community Member

Anyone else seeing their thermostats are getting rolled back to 6.1.1-21? We have 3 that have been experiencing similar symptoms as on this thread and as of tonight, two have been rolled back and are functioning normally. The third still has 6.2-22 and is not working right yet...guess the geniuses at Google finally figured out what a f-up 6.2-22 is.

Neelfsu
Community Member

Wow that's great they actually rolled back to the 6.1.1-2 version on 2 of your thermostats. I still have the 6.2-22 version on my thermostat, but am really hoping they will roll back mine too. Thanks for sharing!

gwade
Community Member

All three now updated, all three functioning normally. Thank god...going to be 2 degrees in Truckee this weekend!

HK21
Community Member

Guys, I am not following you. How did they update (or so called rollback) without Wi-Fi connectivity which is lost due to this rogue firmware 6.2.22. Is there a way to rollback without Wi-Fi connection since mine is not connecting to Wi-Fi or being able to add to Nest account. 

gwade
Community Member

WIFI connectivity was not a problem mine were experiencing. I have Nest E's so maybe there are different symptoms. My Nest E's always had WIFI. My problems were what some others were experiencing in that after a long power outage, when rebooted, they would only hold safety temperature and not call for heat no matter what the t-stats were set to. My issue was fixed (temporarily) when a full factory reset was done, but last night all three were pushed a roll-back apparently by the thermostat gods...I'm not at the house so I didn't do anything.

HK21
Community Member

Got it. I have Nest 3rd Gen self learning and lost Wi-Fi and Neat account link and nice these buggers updated firmware 6.2.22. Anyone with tech background and ideas on how to roll back? Otherwise my Nest Gen 3 is working fine. 

David1
Community Member

Some are getting rolled back to prior release .21 on date 12- ############ without all the bugs …who else is seeing google initiated roll back to to -21 ? 

Yep I posted that as of 2pm today they rolled me back and furnace is working correctly.  No notice or warning that this was coming to be done.  

markvw3
Community Member

I am so frustrated! There was a huge snow storm and power outage in the Tahoe area.   Once power came back and internet was restored a few days later my Nest E thermostats came back online (I have 3 due to zoned hydronic heating) and none of them worked correctly. After driving up to take a look, I had to restart two multiple times to get them to work and reset one completely to get it to work. There is a huge issue here that this thread has been discussing for a few months. The thermostat looks like it’s on, I can change the temp manually, I can change the temp via the app, but it won’t activate my heat. The whole idea of a “connected” thermostat is to be able to remotely manage my heat to avoid issues like frozen pipes. It’s not that hard. I paid a premium for 3 Nest E because I don’t have a common wire after having to ditch the fancier Nest thermostats b/c they continually ran out of charge (understandably). But they also had the same issues with connectivity. Stop adding all these advanced features and just make the thing work correctly. The common thread is firmware 6.2-22. I am in tech and I know how this stuff work internally - this is not good. I may just bite the bullet and go with another brand and have 3x common wires installed by an electrician. Google / Nest fix this issue!

Nest E thermostat here.  I haven't had any connectivity issues yet.  It wouldn't heat any higher than the safety temperature.  Someone on another thread suggested turning the safety temp off.  I tried that and it's heating correctly for now.  Hopefully Google will fix this firmware issue.

LeaDees
Community Member

My two Nest thermostats stopped turning the furnace after they were automatically upgraded to 6.2-22. At first I thought it was one of the Thermostats (before I realized they were both having a similar issue), so I purchased a new one. It had the same problem. Now I have THREE bricks--none of them heat properly or consistently--all with the same firmware. I called support and they said to do a factory reset. I did for two that are currently installed. One may be working (I have to test a little more) but the other one is still nonfunctional. It starts to heat for awhile then stops. I try to turn the heat up to no avail. The thermostat (in person or through the app) just stops communicating with the furnace after shutting down the heat. WHEN IS GOOGLE GOING TO FIX THIS!? At least let us go back to an older version of the firmware which worked for years! I smell a class action law suit coming on!

bsangeor
Community Member

Most of us in colder climates can't wait for Google to fix something that they won't even admit is a problem.  I spoke with several tech support people who were only concerned about whether my thermostat was still in warranty.  They wanted pictures and documents from the service technician with no intention of reimbursing for the costs.  Time to dump the Nest and get a more reliable thermostat.

LeaDees
Community Member

UPDATE: they downgraded one of my thermostats (without telling me they were doing so) and it fixed my problem. I installed the third thermostat and did a factory reset and it worked. So my system is now stable once again but I spent lots of money and time that I won’t ever get back.