Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can not get Google Alexa to find Nest G4CVZ

Community Member

Have updated the nest app on my phone to the most current
Have tried add the device via the Alexa add device
Thermostat  /  google nest  / and followed the Alexa instructions (never finds it)

Tried to to scan the QR code on the back of the thermostat using Alexa but it states to go to the google home app
The thermostat is installed and google home is running and I can change settings in the google home app

 Alexa just can't find the device even when the thermostat and phone are in the same room

I checked on the  thermostat and it has a MAC address so it is connected to my local network

I want to be able to use the amazon Alexa to be able to utilize the thermostat controls as well



Community Member

Having same issue after i disconnected from all apps and tried to reset it up. Couldn’t get Alexa to turn furnace OFF although it says it was off and the apps showed it was off the actual thermostat was still running the heat. That’s when i rest everything and now i can connect to Alexa. Frustrating.

Community Member

Also having the same problem. I had to get a new nest after an issue with the first. The first was hooked up to Alexa. This one under the new app version will not connect. 

Community Member

Having the same issue I cannot find the nest on my Alexa devices as well on the Alexa app on the phone is there any solution?

Community Member

I have found a solution to this problem as I was having the same problem and contacted google… What you need to do is go into the Google Home app and tap on your icon in the upper right hand corner. Then tap on home app settings.  Then tap on partner connections.  Then tap on Amazon, then scroll to the bottom and make sure all thermostats have been selected.  Once you have done that, you can tell Alexa to discover devices again… FYI I had to do discovery twice, but it did find it… Hope this helps